Cannot find external hard drive

  hefs 12:48 17 May 2012

Hi I have just bought a buffalo mini station to transfer files from my pc as run out of space. I have connected to my pc via usb but cannot see it under My computer and have also tried disk management. Is there anything else I need to do ad I assumed id just plug it in and then be able to drag and drop files to release space? I am not great with pcs so can anyone please advise? Thanks

  lotvic 13:11 17 May 2012

Does the blue light come on? It should just be plug n play. Is it this one?

Have you tried it in a different usb port?

  hefs 13:43 17 May 2012

Yes that is the one and yes the blue light comes on and makes a slight whirring noise so sounds like its working ok. The pc makes the ding sound also when connected. Would it be because the pc has so little memory space left as it is really low and nothing is working well which is why I bought the external hardrive?

  Jollyjohn 13:53 17 May 2012

Is your USB port supplying enough power?

My ext. HDD has 2 USB connectors and on my laptop I need to plug them both in to get enough power.

  hefs 14:11 17 May 2012

I've no idea? How can i tell? I only.have one output from buffalo drive though so not sure how is do that?

  lotvic 14:46 17 May 2012

It's prob the usb port on your pc that doesn't have enough power coming out of it to go to the buffalo drive.

Have you got it plugged in the front usb? (they are usually only usb1)

Try plugging it in one on the rear of your tower, they are usually usb2 and have more power.

  Terry Brown 14:53 17 May 2012

Have you tried connecting it to a different PC (i.e. your laptop) and does it work?.

As it is a 500gb drive , and has no independent power supply,are you plugging it directly into the motherboard or via a USB hub. If a Hub that may be the problem.

What is the PSU on your machine as it may not be powerful enough to run the EXT USB as well as the rest of the system.

If you have a spare USB 2 cable, try using that to conect it, as the cable supplied may be of a poor quality and not supplying enough power to run the unit.


  lotvic 15:05 17 May 2012

To rule out if the buffalo drive might be faulty - Trying it on another pc is the next step if it still isn't recognised in any of the other usb ports on your tower.

  hefs 16:01 17 May 2012

Lotvic - just tried usb port at back of pc which doesnt work either. Tried thr laptop and software loaded and could see hardrive under My Computer straight away so not the device itsel. Terry - sorry but i am completely computer illiterate and don't know what motherboard is or the PSU? Don't think i have any spare usb cables that will fit the buffalo

  lotvic 16:25 17 May 2012

Is your desktop pc an 'old' one? The problem obviously is with it as laptop has no trouble with the buffalo drive (so you don't need to fiddle about with it's cables)

A PSU is the Power Supply Unit - where you plug the electric from the mains wall plug into on the back of your pc. A motherboard is the big square flat circuit board inside a pc that everything else plugs into. Terry, I think, was making sure that you were plugging buffalo usb directly into a usb socket on your tower and not into a usb hub (that is like extension with several usb ports on it that then plugs into one usb port on your pc)

Will have a think about best way to free up some Hdd space if you give us some more details of that pc. Might be able to reduce the space allocated to System Restore images which is usually set at 12% of the drive.

  hefs 18:17 17 May 2012

Pc is a dell dimension 5150 Pentium d 820 dualcore and had 6 years so could be deemed as old? Yes buffalo wad plugged into usb ports in the tower as I wouldn't know how to do anything else !!!! Thanks again for your help

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

25 book design and illustration tips

iMac Pro review

Idées cadeaux pour geeks et tech addicts