cannot download xp service pack1

  [DELETED] 02:18 20 Sep 2003

Recently upgraded to a second drive, is added as slave, recognised as E. Copied files from C drive to this new drive in order to format the drive, it came partitioned into 2, 1st partition 74GB NFTS 2nd 30MB FAT. After formatting the C drive, it was still named C, the D was now E sitting next to C on Disk 0 and the E drive (Disk 1) had changed to D. When I try to download the service pack it seems to be looking to install the update on E, although the original software is on the C drive. Hope somebody understands all that. Anybody got any advice to allow me to get the drives back to being recognised correctly and to allow me to download about 30+ updates.

Thanks in advance.

  [DELETED] 04:33 20 Sep 2003

A few clarifications please.

"Copied files from C drive to this new drive". By that I assume you mean you just copied files to the new drive, and you never ran XP from the new drive, right?

"After formatting C drive ..." Presumably after formatting C, you reinstalled XP from the CD back to the C partition (i.e. a fresh installation)? Or did you install XP from some installation files on the 30MB partition?

Drive letter changes. That would seem normal, after a fresh installation of XP, if the new drive has a primary partition. On a new installation of XP to the C partition, XP will start afresh and assign drive letters in the normal way. The drive letter changes you have described are normal.

If you want to change the drive letters, you can (more later), but I'm not sure it will have an effect on the way XP installs the OS updates.

"it seems to be looking to install the updates on E" Are you doing it through the Windows Update site?

Normally, Windows Update will only detect and install updates to the current operating system from which Windows Update is running (this is so even if you have a dual boot). So if you are running XP from the C partition, it should not install updates to other partitions.

Why do you think it's trying to install to the E partition (and are you talking about the 30MB partition, the present E, or the partition on disk(1), the old E?) What indications did you get which made you think it's installing to E?

You're better off clarifying what's wrong with Windows Update first before changing the drive letters. To change drive letters, Click Start, Run, type diskmgmt.msc and press Enter. Right click the 30MB partition, and select Change Drive Letter and Path. Click Edit. You cannot change it back to D immediately, since it's been taken by the partition on disk(1). So change it to any available letter (this is only temporary). Click OK. You'll be warned about changing drive letters. Confirm the action.

Then right click the partition on disk(1), repeat the steps, but now the letter E will be available. Change it to E.

Then right click the 30MB partition again, and change it to letter D, which is now available.

  [DELETED] 14:32 20 Sep 2003

I just copied over my work files no system files and no operating system.
I have tried to install through the site and also with a CD. Both with the same outcome. This is what I don't understand, XP is on the C drive so why is it looking at other drives?
I get a message when it is trying to install that there is not enough room on the E drive, I need to free up another 4 meg.This is the present E. I wasn't too clear on that point was I? To clarify Disk 0 has C with 74gig and 30mb is assigned to E. Disk 1 has 74gig.
I have tried to change drive letters to see if this made any difference but it didn't.

Hope this is clearer, thanks for taking the time to help.

  [DELETED] 11:32 21 Sep 2003

Thanks for clarifying. Unfortunately I don't know the answer, but there may be a workaround.

It may be that SP1 is trying to extract itself to the present E drive, which is too small. (Is there an i386 folder on the 30MB E drive, and was it from there that you reinstalled XP? Just a thought - because if the answers to both questions are yes, it may be that SP1 thinks rightly or wrongly that the source files are on E which need to be updated by SP1 - but that's really a guess).

A possible workaround (worth a try -no promise it will work). Try manually extracting xpsp1.exe, assuming you have the full sp1 file (i.e. no further download is necessary. If you have the sp1 CD, that's the full file).

Create a folder called C:\SP1full

Copy the SP1 exe file to the C drive. If the file is called xpsp1.exe, the location should then be C:\xpsp1.exe

Open a command prompt by clicking Start, Run, type cmd and press Enter.

At the C:\> prompt, type xpsp1.exe -x:c:\sp1full

and press Enter.

After that, go to the C:\sp1full folder. There should be a subfolder called update, in which there is a file called update.exe

Double click the update.exe file, and see if it will install sp1 for you.

  [DELETED] 08:54 22 Sep 2003

If the above method doesn't work, there's an entry in the registry which may possibly throw light on you problem.

Click Start, Run, type regedit and press Enter. Once in the Registry Editor, do not try to change anything yet.

On the left, expand the plus signs to get to HKEY Local Machine\ Software\ Microsoft\ Windows \Current Version\ Setup.

Highlight "Setup" on the left.

On the right, there should be an item called "SourcePath". Tell us what is entered under the Data column (e.g. does it say F:\ or does it say E:\i386?)

Above the item "SourcePath", see if you can see the items "ServicePackSourcePath" and "ServicePackCachePath". If so, tell us what the corresponding data entries are.

Then just exit regedit. Don't change anything yet.

  [DELETED] 13:48 22 Sep 2003

Tried the first option and it didn't work, thanks for the suggestion though.

The second option via regedit looks like this. ServicePackcachePath = c:\windows\ServicePackFiles\ServicePackCache.

ServicePackSourcePath = F:SourcePath = F:
Interestingly enough the BootDir in here is stated as E:\. Surely this should be C.

Any ideas?

  [DELETED] 16:35 22 Sep 2003

Certainly my BootDir is "C:\". The other three entries seem OK to me. You can try changing BootDir to C:\ to see if it makes any difference.

Back up the registry keys first before you make any changes (Highlight registry key, Click Registry > Export registry file)

The other place to look at in the registry is HKEY Local Machine \Software\ Microsoft\ Windows NT\Current Version

There is also an entry called SourcePath there. If it says something like E:\i386, try changing it to F:\ and see if it makes any difference.

I've been proceeding on the assumption that something in the registry is telling SP1 to update something in the E partition. Hence the last and this posting. Of course I may be quite wrong. If none of these suggestions work, I'm stumped.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Microsoft Surface Book 2 15in review

Iglooghost's hyper new music video gives a mutant take on Monument Valley

When is the best time to buy an iPhone?

Quel antivirus gratuit choisir pour un PC ?