Cannot download Net.Framework

  Pastor Joe 16:18 18 Nov 2008

I need Net.Framework to make my Video Driver Control Panel work.

Went to the Microsoft Download Site. Found Versions 1.1, 2 & 3. Tried to download them one after the other only to get a 'Page not Found' error on them all.

Managed to download a Net.Framework Service Pack but it will not run without the service pack.

Is there anywhere else I can get Net.Framework from?

  beeuuem 16:28 18 Nov 2008

Which versions do you need?
Have you tried click here

  Pastor Joe 16:41 18 Nov 2008

Problem solved, found it at

Hi Beeuuem, Tried the Brother Site but it just tries to download from the Microsoft site and returns File Not Found.

There is something silly going on at the Microsoft Download Site, No version of Net.Framework is available for download. They say they are but when you try to download any of them they are just not there.

  iscanut 16:41 18 Nov 2008

I would expect problems if you tried to install one after another, but no to download them. Try beeuuem's link and download and install just the latest version.

  beeuuem 19:01 18 Nov 2008

You may have a settings problem as I can download from M/S and Brothersoft sites.

  TN 19:30 17 Jan 2009

I got a message that an automatic download was unable to install. I went to the Microsoft web site to get details and was told that my .NET framework was corrupt and the security update could not install. It referred me to a page of instructions how to repair the .NET framework installation.
I was told to uninstall all versions of the programme on my computer and take a note of each of them. After running a registry clean or running Windows Install Clean-up, I had to re-boot and then re-install all of the ones I had deleted. I downloaded and installed v 1.1 and all went OK. I then had to download and install v 2.0 but when it started to install it gave a message that it was not compatible with the already installed version and was stopping the installation. I tried all of this again with the same result. I then uninstalled the v1.1 and tried to just install the latest version (3.0) This started to install for about three minutes and then said that there was a problem and it would roll back the installation as it could not continue!!
Have you come across this before anywhere?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

WWDC history: Apple's product launches since 2005

Comment importer des contacts d’un iPhone à un autre iPhone ?