Cannot defrag past checking for errors stage

  [DELETED] 20:19 29 Sep 2003
Locked

When I try to defrag my c drive on windows 98 2nd edtion. The system will not defrag and doesn't get to 10% it justs keeps restarting. It never gets past checking for errors. Tried to start in safe mode but my computer won't start in safe mode. Shut down any programmes that were running at the time including the virus checker.Can anyone offer any advice.

  [DELETED] 20:30 29 Sep 2003

Normally what causes this is another program running in the background.Have you got a virus checker on?,or other program,if you have disable it,only temporarily,until you have finished de-fragging.

  [DELETED] 20:31 29 Sep 2003

Sorry-cant read,doh.

  [DELETED] 20:33 29 Sep 2003

Further to 3Toed's response,another cause of this can be if you don't disable your toolbar,again you can restore it after the defrag.

  [DELETED] 21:06 29 Sep 2003

After my lame reply above wiggyaggy(totally off colour and feeling embarrassed)-I wonder if your drive is getting full,i managed to find a plausible explanation if it is full-
In order to successfully defragment a disk there needs to be sufficient free space available to put the fragmented files back into whole files. There must be enough room for the largest fragmented file to be saved twice (while it is being processed). If the smallest fragmented file is too big to fit in the largest block of free space then it will not be possible to defragment the drive at all. In both cases, some files will need to be deleted before proceeding.

  [DELETED] 09:05 30 Sep 2003

I'll try to delete some more files and disable the toolbar. thanks

  [DELETED] 09:14 30 Sep 2003

3Toed is correct in what he/she said, wiggywaggy, but if you feel that that solution isn't working, you could try Diskeeper Lite click here as an alternative to the Win 98 defragmenting application. It is a lot faster and, in my experience, causes less hassle.

  [DELETED] 09:58 30 Sep 2003

sorry to jump in, but how do you disable the toolbar.thanks

  [DELETED] 12:02 30 Sep 2003

Morpheus, right-click an empty grey space adjacent to your 'Quick Launch' toolbar at the bottom of your screen, select 'toolbars'then move down and uncheck 'Quick Launch'. Remember to reverse everything after de-frag complete. This is for 98SE, don't know about other OS. HTH TR

  [DELETED] 12:12 30 Sep 2003

downloaded you suggestion. problem now solved. thanks

  [DELETED] 12:23 30 Sep 2003

thank you for that...............

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

How to watch the World Cup for free on TV and online

Adobe's brand-new video editing app Project Rush works across your computer, tablet and phone

Best external graphics cards (eGPUs) for Mac

Les meilleurs jeux pour Android (2018)