cannot connect to usb adaptor

  goat0_7 12:53 14 Oct 2008

hoping this will be very easy to resolve...

i have an O2 broadband router which connects to the internet through an ethernet cable with no trouble at all. there is also no problem with this when i connect to my wii console as well.

recently i bought a belkin wireless g+ adaptor to save messing around with a cable from my computer to the phone line (my last belkin adaptor broke). despite my router telling me everything is fine and having this confirmed by O2, there is no connection to the usb adaptor so i cannot connect to the internet at all. all that i am being told is that there is a dial up connection but i have used broadband with other belkin adaptors in the past with no trouble at all. please can someone confirm what the problem may it an ip address issue?? i have reversed the last windows vista update as that was preventing me from getting on the internet on my pc at all.

O2 advised me that my only option was to uninstall vista and start all over again but that seems a bit drastic and i really don't want to be doing that!!

  setecio 14:15 14 Oct 2008

Is it definitely a wireless router ?

Is wireless enabled in the router ?

What is the router make and model number ?

Have you loaded the vista drivers for the belkin adapter ?

Have you then searched for wireless networks ?

  goat0_7 20:02 14 Oct 2008

not sure of the make and model number - it was provided when i signed up to O2 so it is there firmware etc.

it is certainly a wireless router as i have used other belkin adaptors. i have simply upgraded my old standard belkin adaptor with the the g+ version, so this is a replacement model

i have very little knowledge of what to do which is proving the most frustrating thing!!!

thanks for your assistance

  goat0_7 16:06 12 Nov 2008

is there a link to where i can find the vista drivers? i think this is causing the problem. i have tried everything else in the mean time!!!

  setecio 21:36 18 Nov 2008
  goat0_7 14:03 05 Mar 2009

after a lot of phone calls to O2 broadband, I think have finally got to the route of the problem - the isatap.lan in my device manager. is there a patch for this?? i have an e system desktop bought from PC World about a year a go, if that helps...i have looked at other solutions and it suggests uninstalling but i dare not do this and "rollback" driver is greyed out! i can still get online using the ethernet cable but i have to move my router every time i go online with my wii as the connection keeps dropping out using the "old fashioned" way....thanks in advance!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Sam Falconer transforms science and geology into digestible, elegant illustrations

HomePod review

Les meilleures séries Netflix (2018)