Cannot connect to DHCP sever

  jbm84t 06:28 03 Jul 2008

I am really stuck here. I have done searches here and google for fixes but nothing has helped.

We have two computers and no router, only a modem. The laptop can be plugged into the modem and connect no problem (not strictly true; see below). The desktop initially connected to the internet. At some point I restarted and it no longer connected. I was then able to connect after turning off the modem and the computer and turning both back on. Now nothing seems to get it to connect. Since then I have been fooling around and had the following symptoms (not sure what would be useful here):

1. Have had a similar problem on every network I have tried to connect this computer to. Always just did what tech support told me to but I can't get support through my ISP this time. Not sure what we did in the past.
2. ipconfig/release, ipconfig/renew gives an error saying cannot connect to the DHCP server.
3. setting up a static IP address didn't help. Although, I didn't really know what I was doing. I just used the subnet mask, default gateway, and DNS server addresses I got from the laptop using ipconfig/all (when the laptop was connected).
4. used winsockxpfix.exe with no luck.
5. CAN ping the following address (no idea what it is but was suggested for someone with a similar problem)
6. Often if I hook of the desktop to the modem then connect my laptop I must turn the modem off/on to be able to connect to laptop to the internet.
7. I checked the Event Viewer and there are bunch of warnings and errors for the last few days. A bunch of given IP address 169.254.... warnings, a few lease on address expired warnings, a few "TCP/IP has reached its security limits on number of concurrent attempts" warnings.

Any ideas? Any help would be greatly appreciated.

  brundle 07:17 03 Jul 2008

Ping means TCP/IP is OK.
What make/model of modem, what ISP?

  jbm84t 12:42 03 Jul 2008

Thanks for the response. The ISP is Comcast. The Modem manufacturer is Scientific Atlanta model dpc2100r2. I also wanted to add, I have SP2. Also it has simply worked it self out once before and clearly worked once at this new location but I have never not had problems with this computer and internet connection.

  brundle 14:01 03 Jul 2008

It sounds as though the swapping of devices is problem. It will register the MAC address of each device connected and probably need resetting (ie switching off, disconnect device #1, connect device #2, switch on) for you to swap devices and still have the modem recognise it.

You ought to get yourself a router to allow you to share the internet connection without having to physically swap connectors.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?