cannot assign a valid ip address

  generous88 22:21 24 Aug 2008

hello...i've got a belkin wireless router and it was working properly...i had a problem with my laptop and had to install windows again..
since error occurs when i try to connect to the network saying that it could not assign a valid ip address...the gateway and the ip and all those fields are Zeros..
what shall i do regarding that the laptop connects to other networks properly...and there's a pc here and it connects to the router properly...and i tried to copy the ip and the gateway and the subnet but it still doesnt work
thanks alot

  brundle 22:47 24 Aug 2008

Does it work if you connect the router and laptop with a cable?

  generous88 22:49 24 Aug 2008

yes it works

  brundle 23:02 24 Aug 2008

Are you using the latest wireless drivers for your hardware? Are you using the built-in wireless management software or a third party version? What version of Windows?

  generous88 23:39 24 Aug 2008

its the latest drievers...and the windows is XP SP2

and it's a built-in wireless

  brundle 23:48 24 Aug 2008

OK - are you using Windows to manage the wireless card or the software that came with the laptop? Have you tried temporarily disabling the security on the router to see if you can get the laptop to connect?

  generous88 23:53 24 Aug 2008

sorry didnt get you..but i'm not able even to access to the router..when i type the default gateway in the explorer as i used to, to access the doesn't access

  brundle 23:55 24 Aug 2008

You mean accessing the router config while using a wireless connection? You access the config with a wired connection - and you just said that works. Unplug the cable to test the wireless when you've made changes.

  brundle 23:55 24 Aug 2008 for Belkin, usually

  generous88 23:59 24 Aug 2008

ok got,firewall, and NAT are all enabled...shall i disable something ?

  brundle 00:01 25 Aug 2008

Disable wireless encryption - probably under Security. Leave NAT and firewall as they are. Disconnect the cable. Can you connect successfully wirelessly after that?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

HomePod review

Streaming : Netflix ou Amazon Prime Video ?