Cannot assign printer to a USB port

  [DELETED] 18:10 22 Sep 2007

I have just had my PC fixed and am having to re-install all the devices as the hard drive and motherboard were replaced.

When I run the Epson Stylus CX6600 disk it searches for the USB port but fails to find it. I have checked the cable etc and I think all is o.k. I had no problem using the software with this machine when I first bought the printer and had also used the software to install the same printer on an old windows 98 machine only a couple of weeks ago when my main computer was away.

If I stop the search for the USB port the setup completes but the LPT1 port is configured and if I retry the software says the printer is assigning to PORT (but the printer does not show up in Control Panel).

I have attempted to manually assign a USB port using Control Panel but there doesn't seem to be a way to do this.

Could there be a problem with the Windows XP installation on my machine? Anyone got any other ideas?


  Technotiger 18:18 22 Sep 2007

Only guessing but perhaps if you get the latest driver for your printer??

click here

Registration is free and painless!

  [DELETED] 18:18 22 Sep 2007

Find C:\WINDOWS\inf\usbprint.inf, right click and select Install, you may be asked for the location of "usbprint.sys", it should be in C:\WINDOWS\system32\drivers\ otherwise you will find it on your XP CD (maybe compressed and called usbprint.sy_) - reboot and try the printer installation again.

  Stuartli 23:45 22 Sep 2007

From Start>Settings>Printers and Faxes>highlight your printer>left click>Printer tab<Ports tab>Select and OK USB port.

  Stuartli 23:47 22 Sep 2007

Sorry, missed Properties after Printer tab (doing it from memory).

  [DELETED] 13:31 23 Sep 2007

Thanks folks - still a problem - here is what I have tried...
brundle - found the usbprint.sys file (but not in the same location as you) and copied it to C:\WINDOWS\system32\drivers - did not seem to make a difference .
Technotiger - downloaded the latest drivers from the Epson site but still no difference.
Stuartli - I am assuming this is in control panel as I don't have a "Start>Settings" option (at least I can't see it). But in Control Panel on Printers and Faxes I didn't see an option to select a USB port

Interestingly I have attached and loaded two other USB devices and failed with one other.

The two successes were with a Logitech webcam and BT Digital Media Player. In both cases the software was loaded first and then the Windows "Found New Hardware" wizard was used to find the drivers and do the final set up (I tried using this with the printer drivers I downloaded from Epson - it ran through but then fails with the message "the specified port is unknown" The Epson manual says you should just cncel the wizard when it appears).

The device that failed was an Integral High Speed USB2.0 card reader (originally supplied with the PC). The manual for this says there is no need to load drivers for XP but when I attach it to a USB port the "Found New Hardware" wizard again kicks in and fails because there are no drivers!! (With the previous machine this reader was automatically detected as soon as it was plugged into the USB port).

One last thing - the motherboard is an Asus A8R-MVP which has PCI Express slots (whereas my old one was an Asus 8VR deluxe which was AGP). I notice that for the new board there is a BIOS setting in the Advanced menu called PCI PnP which has the Plug and Play O/S setting as Yes (where No means "Let the BIOS configure all the devices in the system" and Yes means "Let the operating system configure Plug and Play (PnP) devices not required for boot" (sic). Could this be the culprit?


  Stuartli 13:32 23 Sep 2007

>>I am assuming this is in control panel as I don't have a "Start>Settings" option (at least I can't see it).>>

No, it's exactly as I wrote it (from your Desktop - the Start button is bottom left of the page).

  [DELETED] 15:58 23 Sep 2007

Is USB 2.0 enabled in the BIOS? When you view USB devices in Device Manager, are there any entries with the word `Enhanced`, this usually denotes USB2 support. It shouldn't make any difference with a printer, but it's worth a look.

  [DELETED] 18:19 23 Sep 2007

>>I am assuming this is in control panel as I don't have a "Start>Settings" option (at least I can't see it).>>

Actually, yes, you can access "Printers and Faxes" from Control Panel.

  Stuartli 20:50 23 Sep 2007

True, but it's just that bit quicker from the Settings sub-menu...:-)

  [DELETED] 10:21 24 Sep 2007

StuartLi and PaulM - Assuming that we are talking about the same area in Windows for Printers and Faxes then the only available options are "Local Port; Microsoft Document Imaging Monitor; Standard TCP/IP Port". There is the option to add a new port type but then I get asked to "provide a printer INF that contains the port monitor installation information". I do not know if I have this information or which file it is in. Certainly it doesn't seem to be in the Epson drivers.

brundle - yes - in device manager, under Universal serial Bus controllers I have a Standard Enhanced PCI to USB Host Controller entry amd I assume that this is allowing USB2 support

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Microsoft Surface Book 2 15in review

Illustrator Amy Grimes on how setting up her own eco-brand led to success with clients too

MacBook Pro keyboard issues and other problems

Test : l’enceinte connectée HomePod d’Apple