Cannot Access C Drive from A prompt

  EvoPaul 18:22 18 Jul 2012

For last few years I've been using an (ex-office) Compaq Evo N410C, standard fit running Win2Kpro, acquired around 2005 when company updated their technology. Although it still has mobile networking software installed (and a number of virtual drives, like M, U, T, and X), I've just been using it as an offline standalone pc for Office 2003 apps, music store, notes, etc. My old username/pw combination has always worked fine (albeit bit of a pain !), and for ages I've intended to backup my stuff and wipe the drive to install more modern O/S etc. Well, you know that horrible feeling of regret when you wish you'd done what you intended to ?

Week ago I was poking around the the Network Settings area of Control Panel - just browsing - but I think I've set the pc to Workgroups. I did cancel the dialogue box that said something about "You have to restart for the settings to take effect" but ...

Now I find my usual username/pw combination doesn't work any more. Course, I've tried every combination I can remember - even imagine - but no go. Schmuk ! Machine works fine, boots on HDD to Win2Kpro, but of course stops loading at the password challenge. Have tried (via F8) Safe mode, Last Known Good Config, etc. Still get to the password challenge - and that's it. Schmuk !

Need to reset that password via WINDOWS/System.ini, but I cannot see the HDD at all. Booting with various DOS versions on floppies and asking for "dir c:" at the A:> prompt, it always returns "Invalid drive specification". And I've tried every other letter to z with same result: doesn't appear to be seeing the HDD via DOS. Cant see it via editors like dosshell or qbasic. reports only A: drive fitted, so that cant see the HDD either.

Have looked in the BIOS ("Setup", via F10), but no clues. Doesn't challenge for p/w, and have Restored Factory Defaults just in case.

However, a Win98 boot floppy reports "... drive C does not contain a valid FAT or FAT32 partition", and suggests running FDISK. Well, that might get me to a position to install an update O/S (have XP pro), but it would erase all data so I'd lose all my stuff: am looking to avoid that, of course.

Anyone got any ideas please ?

  lotvic 18:39 18 Jul 2012

Take Harddrive out and hook it up as a slave to another pc. Copy the data you want to keep to the harddrive of other pc (or another ext harddrive etc.). You could also wipe/delete all on the drive after you have copied what you want. That leaves you free to put it back in old pc and install XP pro.

Don't forget to check your copied data is okay before you wipe the old drive :)

  Fruit Bat /\0/\ 18:52 18 Jul 2012

Windows2k/XP Try this:

1- boot to the windows xp/2000 CD ,

2- press enter to start setup ,

3- press F8 for the license agreement ,

4- when you get the option to repair the current installation press R to do so ,

5- let it run through and for windows XP wait until it reboots and is installing, devices then

press shift F10 to open a command prompt. For windows 2000 wait until it is registering

components then press shift F10 to open a command prompt. ,

6- In windows XP either type in "nusrmgr.cpl" w/o quotation marks at the command prompt and press enter. For windows 2000 type in "control.exe" w/o quotation marks and press enter. This should open up the user accounts applet in XP and the regular control panel in 2000. ,

7- select the users and change or remove their passwords accordingly, apply settings and close the control panel windows and command prompt windows so that just setup is running again. ,

8- let the inplace upgrade finish.

The user should now be able to log in when it finishes and not have to reinstall the programs like in a parallel install.

  EvoPaul 20:56 19 Jul 2012

Your suggestion looks interesting, FruitBat. Am keen to try that. First, though, am gonna try a copy per Iotvic's suggestion. Feels safer to get a copy of the data before letting the software magic run. Am off to get me toolkit ...

Many thanks to you both for your helpful suggestions. Cheers.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Illustrator Juan Esteban Rodriguez on creating highly detailed official film posters for Star Wars…

iMac Pro review

Comment savoir si quelqu'un a bloqué votre numéro de téléphone ?