Cannon Scanner Problems

  vandango 17:51 19 Sep 2004

I have recently had problems with my scanner, it used to work fine but now the error

"Unable to open TWAIN source

Please check connection

Then re-start Toolbox"

appears each time i try to use it. I have tried uninstalling/reinstalling the software and also tried unplugging/replugging in the usb cable and xp has loaded a driver each time.

Any ideas or advice?


  howard60 17:55 19 Sep 2004

check that the system lock on the underneath has not got pushed to the locked position

  Mango Grummit 21:11 19 Sep 2004

This happened to me once. What I did (eventually and after trying other things) was to unplug scanner, remove all traces of all related items from system. Clean the registry and reinstall.

IMPORTANT to follow exactly the installation instructions as the order in which you do things matters.

  wysiwyg8 21:45 20 Sep 2004

I have the same problem, my new Canoscan 3200F with USB2 connection is recognised by XP, drivers loaded with NAV dissabled installed and shown in device manager etc as working correctly and no conflicts, however when I try to aquire from any of the various applications with a twain input not only Canon's own software, I get an error stating "Cannot comunicate with scanner". In the scanner properties tab in settings the scanner is shown as status "unavailable" all USB devices are OK and the scanner works fine and is instantly working on a PC running ME so there is nothing wrong with the scanner or the USB Cable. The only thing I have not done yet is install Service Pack 2. I ran the Canon app deldrv.exe to make sure the drivers were the latest.. Any thoughts?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Turn a photo into 16-bit pixel art

iMac Pro release date, UK price & specs

Comment suivre le parcours du père Noël ?