Can anyone PLEASE help me finally sort this out?

  futurist 15:23 18 Aug 2008

I have had no luck at all :(

Sorry for the long post, but I want to be as thorough as possible.

I cannot connect to my Vista computer's shared folders from any other computer on the LAN. One computer is running XP Pro, the other 2 are also running Vista.

I get the error:
\\SDC Is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Access is denied

I would prefer not to have to create any new users on any of the computers trying to access it, but rather just use the user that is already trying.

On the Vista computer with the problem:

Network Discovery is turned on, and as a Private Network.

File Sharing is on, no PW protection.

Right clicking the shared folders, I have "Everyone" added, with "Allow" checked all the way down the list of permissions.

I have the LLTP installed on the XP computer.

That's all I can think off off the top of my head.

When I try to enumerate the computers on the network in Explorer, sometimes the computer shows up, sometimes not, (same happens from the Vista PC when trying to see the XP computer sometimes), but ALWAYS I get that error when trying to access the Vista PC.

I am also using a DLink Dir-655 router.

Can anyone PLEASE help!

  mgmcc 16:40 18 Aug 2008

Can you access the "Public" folder in the problem PC? If not, then it may be a firewall issue that is blocking access.

  Marko797 17:03 18 Aug 2008

isn't it supposed to be a 'private' network instead of 'public'?

I'm sure I was reading something to that effect the other day on MS Technet.

If I'm wrong, then I'm sure someone will jump all over me.

  futurist 18:23 18 Aug 2008


I have the Public folder sharing turned off, but I have had it on in the past with the saem problem. also, I can't access that computer at ALL (any folders), because it says I dont have permissions for the whole computer (not just certain folders).

I have windows firewall turned off, and no othr 3rd party firewall installed.

The network is set to Private, I think I mentioned that in my OP =)

  Marko797 20:32 18 Aug 2008

yes u did mention it, sorry, missed it.

U need someone with better knowledge than me on this.

  mgmcc 08:04 19 Aug 2008

As a first step I would certainly enable Public Folder Sharing as that is the least problematical "network share". If that isn't accessible, it is unlikely that anything else will be.

<<<< because it says I dont have permissions for the whole computer (not just certain folders) >>>>

The claptrap about nobody having permission to do anything is a "generic" message created by Windows whenever there is a problem accessing a remote computer over the network. It is extremely unhelpful and frequently quite incorrect.

Is this Microsoft article about File Sharing in Vista of any help? click here

  Eric10 09:53 19 Aug 2008

I once had a similar problem with a friend's laptop and had tried everything I could find out to resolve it. I finally found a page on the Internet where someone was saying that some major laptop manufacturers were sending out their Vista laptops without the Client for Microsoft Networks installed. Well, even though this seemed ridiculous, it had to be worth a quick look and I was amazed to find that had been the problem all along.

So it could be worth a quick look, even if just to rule it out. look in Network and Sharing Center, Manage network connections, Wireless Network Connection Properties or Local Area Connection if you're not wireless. Make sure that there is an entry for "Client for Microsoft Networks". If not then install it by way of the Install button then reboot.

  big_dog_smithy 23:10 21 Aug 2008


This is due to NTLM hash compatability (V1 to V2) and the fact that Vista has the compatibility mode to off by default.

Read here from google.

To allow NTLMv1 or LM challenge-response operations, first become a user
with Administrator rights. Next, run the program secpol.msc. Under Local
Policies then Security Options, there should be something that reads,
"Network Security: LAN Manager authentication level." By default, "Send
NTLMv2 response only" is selected. There are a few options available, but
choosing "Send LM & NTLM - use NTLMv2 session security if negotiated" seems
to make the most sense. Everything should now magically start to work if
using non-NTLMv2 aware systems.

  Marko797 12:36 22 Aug 2008

Not sure if this will help. I've had the same problem as u with this. However, found this article this morning, but haven't tried it yet.

You might find it useful:


What solved my problem was information from this Microsoft tech article: click here. In the section "Common Questions with Windows Vista File and Printer Sharing", subsection "Using a Third-Party Firewall" is a list of incoming UDP and TCP port traffic that must be allowed through the firewall on each machine in order for file and printer sharing and network discovery to work. The Norton firewall on the XP box was only allowing six of the required nine to pass. And that was after I added a couple myself, before seeing the Microsoft article. I didn't confirm how many of the required ports were passing on the Vista machine, I just applied the fix below.

I added two rules to the firewall configuration on each computer and put them at the top of the rule stack (so they would override all rules below them). One rule allowed incoming UDP traffic for ports 137, 138, 1900, and 3702 from machines with IP addresses that could be assigned by my router (this is called the DHCP client range and is usually configurable on the router's admin screen). Mine happens to be through The other rule allowed incoming TCP traffic for ports 139, 445, 2869, 5357, and 5358 for the same IP address range.

Note - If you can't add UDP and TCP port rules as above to your firewall but can specify trusted computers, you might have some success by putting the router's entire allowed DHCP client range of IP addresses into each firewall as "trusted"."

Let us know if this helped solve ur problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?