Bulit-In Wireless Not Working

  s99Raj 16:13 28 Sep 2009

I have a Fujitsu Siemens Amilo Li 2735 laptop.
It cam preinstalled with Vista Home Premium, which recently crashed, and so I decided now was a good time to format and install it back on again.

All went smoothly, plus I downloaded the latest drivers off the Fujitsu Siemens website, and all went well again.

In the Device Manager, there are no yellow exclamation marks or question marks. However, the built-in wireless isn't working, despite the fact that the internal Wireless 3945ABG is showing up as having been installed and working fine.

To switch the wireless on normally requires pressing Fn+F1 but his has no effect. The Fn + F3, F4 or F5 for the sound work OK, but the Fn + F8 or F9 for the brightness do not.
The Fn + F12 for Sleep mode works fine too.

What could be wrong?

  chub_tor 16:20 28 Sep 2009

I realise that this click here will not cure your laptop problem but it will allow you to connect to the internet while you sort your laptop out. I presume you have tried all the obvious solutions such as Right Clicking on the network and selecting Diagnose and Repair.

  s99Raj 16:32 28 Sep 2009

Yes, I tried the Diagnose and Repair but it just told me that the wireless was switched off and that I must switch it on, which of course doesn't work.

  Fruit Bat /\0/\ 16:41 28 Sep 2009

The Wireless Card must be activated every time Windows starts by pressing Fn+F1 but with this VisualBasic script (put in a startup directory) will be activated automatically (note that I DIDN'T wrote this script, I've found it in click here):

Code: Select all
Set WshShell = WScript.CreateObject("WScript.Shell")

Set oExec = WshShell.Exec("C:\Program Files\Launch Manager\WisWBSet.exe")

do while WshShell.AppActivate("Wireless Status Option")=False
WScript.Sleep 100

WScript.Sleep 100


  s99Raj 16:45 28 Sep 2009

Thanks for that Fruit Bat.
I'm afraid I know NOTIHNG about Visual Basic or how to use it.
What exactly do I do with the script?

  Ashrich 18:39 28 Sep 2009

You want Launch Manager V_1.4.9 to get the hotkey for the wireless working , click here , use the wizard to get to your laptop/notebook then when you get to the drivers for Vista 32bit click on Tools and Utilities .


  s99Raj 19:05 28 Sep 2009

Thanks Ashrich.

Launch Manager worked!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

How to use 3D Touch on iPhone

Comment importer des contacts d’un iPhone à un autre iPhone ?