Buffalo HD-PET640U2/R-EU external HDD not recognised

  alexei F 23:55 23 Nov 2012

Hello. I've had the above drive for about a year & a half. It worked fine (on Win XP Home) up until a few days ago, when I connected it to my new laptop (Win 7).

On connecting, a warning message came up saying that Windows had detected disk errors - did I want to scan it? I said Yes, it completed the scan (no errors), but I couldn't access any of the files in Windows Explorer. I Safely Removed USB Hardware and tried again, but said No to the error scan ("Are you sure, some files may be corrupted?"). On continuing, I could see all my files.

I then selected Windows Scandisk, and once the scan completed the HDD was very slow to select. It didn't show any of my files again, and showed the following error messages whenever I tried to access it:

Local Disk (E) You need to format the disk in drive E: before you can use it. Do you want to format it?

Error checking The disk check could not be performed because the disk is not formatted. The disk check could not be performed because Windows can't access the disk. Would you like to format the disk?

Location is not available E:\ is not accessible. The volume does not contain a recognised file system. Please make sure that all required file system drivers are loaded and that the volume is not corrupted.

I have tried it on all 4 USB2/3 ports, and my other Buffalo external HDDs work fine.

The HDD appears as 'Buffalo HD-PETU2 USB Device' in:

Control Panel\Hardware and Sound\Devices and Printers

Control Panel\Hardware and Sound -> Device Manager

and in

Control Panel\System and Security\Administrative Tools -> Computer Management -> Disk Management

as '596.17GB RAW Online & Healthy'. My other HDDs appear as 'NTFS' or 'FAT32', not 'RAW', and I think (but am not 100% certain) that I'd formatted the problem disk to FAT32 when I bought it.

In My Computer the disk only registers as 'Local Disk (E)'.

I have tried to update Drivers but Windows says I already have the most up-to-date ones for the drive.

I also tried reassigning the Drive Letter to (K), but no change.

This disk was the backup for my most important files when I changed to my new laptop, and so I really don't want to lose them. I've read on some sites that I can still attempt to recover the files even if I format the drive (as long as I haven't written anything new to it), but I don't want to risk that unless there's no alternative. Equally I'd rather not try opening the drive casing up - on one forum it was suggested that the 'power supply component' for the HDD might be the problem, and opening the casing, removing the p/supply comp and running the drive in another hard drive enclosure might work.

I contacted Buffalo and they just suggested formatting it then trying to recover the files.

Does anyone have a better idea?



  Fruit Bat /\0/\ 00:31 24 Nov 2012

Test Disk will recover FAT and files see here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)