Buffalo Air Stations WYR-G54 Signal Dropouts

  modelman 23:36 06 Feb 2006

Hi all,

I’m fairly new to networking and after purchasing 2 of the above Buffalo routers I thought all was fine until this problem started.
The routers were purchased with matched 54mbps WLl2-CB-G54L cardbus notebook adapters. Connection was fine with 54mb recorded with occasional drops to 1mb but no real loss of connection.
The problems really started when I added a Safecom usb2 adapter to my main PC.
Connection was a easy using WPA-PSK and 54mbps. Transfer of video and internet between machines was fine.
The problem is the USB adapter keeps dropping the connection every couple of minutes or when it feels like it. I first thought the USB adapter was faulty but have since tried two other makes with the same problem. This issue seems worse when the machine is left static for a short time.
In case it was a clitch on my desktop I placed the adapters in the laptop and the dropouts instantly started on this machine.
I now know that it can only be the router but what is causing this?
Why will it only function reliably with its own make of cardbus adapter? I have read of this incompatibility issue and signal dropouts with Buffalo routers but surely not with Belkin, Safecom and Netgear USB adapters.
The experiment was repeated with the second router with the exact same results.
Since my wife uses MSN very often this constant loss of connection annoys her as she loses her contacts and has to re-log back on each time.

Both machines are running Win XP-SP2
All settings are configured by windows and not 3rd party adapter software
There is no outside interference on the channel being used.
Everything functions fine other than these constant dropouts.
Latest Firmware on router ver 1.10

Questions – Is this a common Buffalo router issue? Could it be a windows related problem? Could the components just not be compatible?

Any comments very much appreciated as I’m now pulling my hair out and the routers will be going back shortly.

Thanks all….Mark

  mgmcc 08:49 07 Feb 2006

I use the same router reliably with two Belkin wireless adapters - a Cardbus laptop adapter and a USB 2.0 adapter.

However, my Cardbus laptop adapter is a slightly older 802.11g one that doesn't support WPA, so I only have WEP enabled in the router. I've seen several reports of connectivity problems when using WPA so it might be worth checking to see if disabling that fixes the problem.

  keewaa 09:32 07 Feb 2006

Some things to try :

Try changing SSID to broadcast on the router. Try different channels. Have you checked for updates for the USB adapter? You could disable the Windows Zero Config servcie and try purely using the adapter software. Can you lower the speed of the USB adapter to make it more stable (in network connections Right click-properites-configure-advanced)

It might be a brand incompatibility as some people do say buy the same brand to avoid issues.

  modelman 10:44 07 Feb 2006

Thanks you both for your response.

I have also found some reports on WPA-PSK problems with this router.
On the link below(4 pages)only around 50% of people could not get this product to work correctly. That’s not very assuring.

click here=

I may have to settle for WEP encryption only.
The SSID is set to broadcast as default. The USB adapters are all running the latest drivers for the tests. The channels tested were clear as far as I could tell.

I may also try using the adapter software as suggested. Do most people opt for this configuration or do most use windows? The Windows option does seem a lot simpler.
I don't really want to reduce the 54mb speed as I sometimes stream video between computers but will conduct some tests at lower rates.

It’s interesting to note that I have also found this issue crops very regularly with other makes of router as well. So how do others work round this annoying problem?

Any further comments gratefully received.

  keewaa 11:11 07 Feb 2006

One thing often heard is stick to the same make (but only relevant to overcome problems, as alot of the time differnet makes work fine together)

I'd imagine most people use Windows ZC and only disable it where problems arise in order to fix it.

I dount any of these are relevant but you can investigate and see (I just have a list);
Microsoft KB884020, DrTCP (change MTU RWIN etc) click here , to detect other networks in range (interfering) click here , try manual windows updates (from start menu) CUSTOM to see if there are any PC/laptop software/chipset upgrades , check wireless authentication used (802.1x can cause), Disable adapter software and use only WZC.

  modelman 11:52 07 Feb 2006

Thanks again.

I will plough through some of your suggested tests today and see what happens. I have nothing to lose.
I am tending to think it’s an encryption issue but we will see. WEP may be the answer until a new firmware is available. We will see. Either that or return it for another make.
Since I am a NTL cable user this router seemed a good choice for the cable modem. Just plugged it in and away we went.
If only everything was this simple!!!

I will have a play today and post any useful results for others with this problem.

  modelman 15:25 07 Feb 2006

Following 3 hours of testing I can conclude the following:

1)There is an issue with the Buffalo WYR-G54 router when using WPA-PSK and other makes of adapter. Intermittent loss of connection is common when machine is left idol for a while.

2)If used with its own make of adapter such as the WLI2-CB-G54L the WPA-PSK encryption seems to work fine without dropout.

3)Using WEP CURES the signal dropout issue but you are not so security protected. Tried all 3 different makes of USB2 adapters with no problems.

4)Disabling Wireless Zero config and running adapter software did not fix the problem. In fact the adapter just kept searching through the channels saying Acquiring Network Address but could not lock in. Switching to WEP encryption fixed this and adapter locked on my channel instantly.


If you purchase this router and intend to mix and match with other makes of adapter components then be aware you may only be able to use WEP encryption for a stable connection. Firmware 1.10 which is the latest does not fixed this problem.
I cannot find any other issues that affect the performance of this router other than signal dropout. I will be contacting Buffalo shortly. Read other forums and they will confirm some of my results today.

Finally a big thank you to keewaa and mgmcc how helped guide me in the right direction.
I hope this info helps someone else.

Again any comments on my findings welcomed as well as a cure for the WPA-PSK issue. This problem may be unique to Buffalo until a new firmware arrives.

Have you had this WPA issue on your make of router and how did you get round it? I would like hear your experiences.

  mgmcc 20:10 07 Feb 2006

<<< This problem may be unique to Buffalo until a new firmware arrives. >>>

I don't believe this issue is specific to Buffalo, which is not one of the most commonly used brands. I have seen numerous posts relating to problems with WPA encryption and don't actually recall any previously being in conjunction with a Buffalo router.

As regards security levels, in addition to WEP encryption you can use the router's "Wireless Restrictions" to specify which adapters are able to connect to either the Internet or the LAN.

  modelman 21:49 07 Feb 2006

The sad thing is that I phoned Buffalo today who had no interest because I was third party equipment. The simply said that they could only guarantee this router to work with their adapters and nobody else’s.
He also informed me that there are no future firmware releases on the cards. Ver 1.10 final. I think that he was implying that this has NOT been their best product to date.
This call has influenced my decision on the next router I purchase.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

ManvsMachine and other artists put Apple's iMac Pro to the test using powerful rendering tools

What to expect at Apple's 27 March education event

Comment filmer l’écran d’un iPhone ?