BT Yahoo continually requesting User Name and Passowrd

  compumac 11:56 22 Dec 2013

For my sins I use BT Yahoo Mail and over the past week or so, after accessing my e-mails and leaving them showing on the screen, I am continually being requested to re-enter my user name and password and on many occasions, despite entering those same details it will not allow me back in until I have tried several times.

The dialogue box asking to "keep me logged in" (or similar) does not always appear, and even if it does, it makes no difference.

I used to leave my Yahoo mail page open during the day without a problem and boot up the following morning and go straight into Yahoo Mail without any request for User details.

What am I missing?

  lotvic 12:06 22 Dec 2013

BT and Yahoo have split up, parted company, divorced and now have moved to separate mail servers.

  compumac 12:24 22 Dec 2013


Yes I know that and have as my home page and accessed my e-mail via the route as displayed without a problem until the past week or so. When I do arrive at my e-mail page and LEAVE it displayed and then return later in the day - I am requested to input my details over again and it does not always accept my input until I have tried two or three times inputting exactly the same details.

  lotvic 12:58 22 Dec 2013

It's not just you forum

  compumac 13:12 22 Dec 2013


Thanks for that link, do not know how I missed that. It would seem that perhaps there is a link with BT Desktop Help and IE11 perhaps causing the problem. I have both installed, BUT BT Desktop Help is telling me that my version of Internet Explorer is not compatible(!!!) and that I need IE6 or above????.

I will have to look further into that.

  compumac 14:03 22 Dec 2013

Further to my problems with e-mail logon I found that BT Desktop Help on my laptop does not function at all!!"

Then I found this:-

"If you already have BT Desktop Help installed or if you've recently installed it and you have Windows 8.1 or Internet Explorer 11, you don't need to un-install it. We'll be providing an upgrade to correct these compatibility issues. "

So it might very well be a compatibility problem causing the e-mail scenario.

  lotvic 14:05 22 Dec 2013

Yes, looks like it's teething problems with the new set up :)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Gmail : comment annuler l’envoi d’un e-mail ?