BT Home Hub connected, but no internet access

  onthelimit1 14:50 19 Jun 2012

This one has me beat! XP PC was on TalkTalk. Owner changed to BT. Owner set up router, but setup CD could not complete the setup. Just plugging the ethernet cable in, icon says connected, but clicking IE displays 'could not be connected'.

A laptop connects OK both wirelessly and by the same cable.

Tried a wireless dongle - says connected, but IE page won't open.

Have brought the PC home where it connects to the internet with no problems!

any suggestions gratefully received!

  Nontek 14:59 19 Jun 2012

Is it possible to compare the Laptops/PCs connections, see if there is any obvious difference - after all, they are both just PCs!

But looks like a Software/setup problem on PC.

  onthelimit1 15:02 19 Jun 2012

Exactly - I just do not understand why one will connect and one won't, yet the one that won't does to my router!

  Nontek 15:16 19 Jun 2012

I would try using the setup CD again, from scratch. Might have been just a glitch during the original setup.

  onthelimit1 15:19 19 Jun 2012

Yes, I tried that - stalled at the same point towards the end. Anyway, the laptop connected OK without running the disk!

  Nontek 15:25 19 Jun 2012

Perhaps a fault with the owners' router, as it works ok on yours? Could be a physical or a setup fault.

Is it a BT supplied Router?

  onthelimit1 15:42 19 Jun 2012

It's a new BT HH3 provided by BT and, as mentioned, a laptop (now 2, as I've tried my netbook) connect straight away when plugged into the ethernet port - it's just the PC that can't access the internet.

  Nontek 15:48 19 Jun 2012

Only other thing I can think of is to completely uninstall any/all HomeHub settings on PC and then try connecting via Ethernet cable. BT HomeHub is generally excellent - I have the same myself.

Otherwise I am as confused as you are!! The confusing bit being, that it works fine on yours?

  onthelimit1 16:31 19 Jun 2012

There is nothing on the PC related to BT. I shall take it back to him shortly and try again. Quite bizarre!

  onthelimit1 20:32 19 Jun 2012

Still no joy. I was, however, able to reconnect and access their old Netgear router and configure it for BT (unlike the Hub, which I could not access from the PC). They're going to ask for a replacement hub and see what happens then!

  Nontek 20:34 19 Jun 2012

Replacement hub may well be the answer.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

WWDC history: Apple's product launches since 2005

Comment importer des contacts d’un iPhone à un autre iPhone ?