Browsers unable to access sites

  oi1889 12:57 29 Jun 2017
Locked

I have been trying to help a friend with a problem whereby they cannot access web sites. The machine is a Dell Vostro running Windows 10 (old but seemingly fine). My laptop works perfectly on his connection so the ISP/router set-up must be working.

He is receiving email successfully via Live Mail. I can ping www.google.co.uk and get a response (also nslookup) so there is some form of DNS recognition happening. Neither Chrome nor Edge will access websites (they just hang). The one exception to that was Google, which I could interact with and make a search but not then reach any of the results. This failed after I flushed the DNS cache (as I expected). It suggests the issue is to do with DNS recognition but then I don't understand why ping works.

Any suggestions gratefully received.

  Govan1x 21:51 29 Jun 2017

Open the router via the internet and where it shows 5ghz and 2.4Ghz. Disable the 5Ghz and just use the the 2.4Ghz and see if that makes any difference.

Not using eset internet security is he as I also had problems with that.

If you give us the actual model number of the Dell we can tell if it is indeed the wireless card that is the problem.

Also another way of finding out is connect the laptop with an ethernet cable and see if it works ok using that.If so it is the wireless card that is the problem.

  oi1889 08:40 30 Jun 2017

Thanks for the answer. Sorry I should have specified that I tried with Ethernet as well as wi-fi and there is a perfectly sound connection to the internet (email is arriving and I could do a Google search whilst Google was in DNS cache). I think it must be something to do with DNS but then don't understand why I can ping to www.google.co.uk and www.ebay.com. I might try resetting the connection to use specific DNS servers (e.g. 8.8.8.8) although I can't imagine why that would make a difference.

  Secret-Squirrel 08:50 30 Jun 2017

Oi, I find that simply restarting the computer solves around one third of Windows 10 (and 8) problems. The only way that's effective is to choose "Restart" from the power menu. Simply shutting down and turning it back on will have no effect in those operating systems.

Likewise, turning the router off for a minute or so then turning it back on may help. I've encountered situations where just one device was affected and that simple tip solved the problem.

Did you try multiple websites in NSlookup? If resolution is successful every time then there's nothing wrong with DNS and you can look elsewhere for the cause of the problem.

To help determine whether it's a Windows problem or one caused by a third-party service or application, boot the computer into "Safe Mode with Networking" and see if that works.

  oi1889 15:14 04 Jul 2017

Thanks, have now got hold of the machine for a few days and found the problem is still there but doesn't occur in Safe Mode with Networking. So I guess my next issue is to try and work out which service or application is blocking the access. Any suggestions for the best method of doing that please?

  Secret-Squirrel 18:23 04 Jul 2017

.........doesn't occur in Safe Mode with Networking.

OK, so that also means that DNS is functioning correctly.

...........my next issue is to try and work out which service or application is blocking the access.

The Windows Event Viewer may just name the culprit that's blocking Internet access although some folks find it a tad daunting and tricky to interpret the results.

Third-party firewalls (McAfee, Norton, AVG Internet Security, etc) can frequently cause problems like yours so temporarily disable it for testing purposes (although your friend may not have one installed).

Malware is another possibility. Try running Malwarebytes Free (in Normal Mode) and see if the scan picks anything up and fixes the problem.

Or, if the onset of the problem is very recent then a Windows 10 "System Restore" will probably fix it. It's usually very quick 'n' easy so it may be the first thing to try. Choose an available restore point but don't go further back in time than you need to. For the best possible chance of success, do it while you're in Safe Mode. If you're not familiar with System Restore then click here and scroll down to the 3. Restore your PC section

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Microsoft Surface Book 2 15in review

Iglooghost's hyper new music video gives a mutant take on Monument Valley

The best Amazon Prime Day Apple deals 2018

Comment ajouter de la musique à une présentation Google Slides ?