Broadband speed drops with new router

  awest3 15:39 29 Oct 2012

Wonder if anyone out there can help with a SKY broadband problem I have. I use a netgear 934gt(the black one). I was having trouble with the wifi range and thought I'd upgrade to an N type router, which supposedly have a better range. To cut a long story short by using the N router my broadband speed dropped from 3meg to 1 meg. Thinking I'd got a faulty router I tried two others with the same result. SKY are being quite helpful but are perplexed by this issue. They have now sent me one of the new HUB routers but this has exactly the same issues. All the usual things have been checked time and time again to no avail. Why would a router slow the access down or visa versa why would a router (934gt) increase the access speeds?

  Number six 22:57 29 Oct 2012

Is your receiving equipment, i.e PC or laptop set up correctly for, and compatible with the 802.11n protocol? Some info here:


  awest3 23:07 29 Oct 2012

I'll ask the sky man when he rings on Wednesday and get back to you. Thanks.

  awest3 14:26 31 Oct 2012

The Sky technicians say my PC etc. is fine for 802.11n

They have never seen this before and are at a loss as to what is causing it. It is easily repeatable and I've switched routers over 10 times to convince the doubters. It can't be the line in as its the same for all routers I've tried. Now at a loss, I'd like to fit the new hub (mainly for its wifi capabilities) but cant due to the line speed drop from 3meg to 1 meg.


  mgmcc 19:30 31 Oct 2012

Are you also experiencing the same drop in speed if you connect to the new router(s) by ethernet cable instead of "wirelessly"?

I know a wired connection may not be practical, but it would establish whether the problem is a "wireless" one.

  awest3 20:09 31 Oct 2012

Hi. Probably did not make myself clear. I am talking about a wired connection. The reason I wanted an n router was for its extra wifi coverage but I've not even tested that yet as the wired connection drops to 1 meg from 3 meg.

  mgmcc 20:33 31 Oct 2012

Go into the Network Connections folder ("Start > Run", type ncpa.cpl and click OK), double click the Local Area Connection and see what speed the adapter is connecting to the router at.

  awest3 21:10 31 Oct 2012

Ta. Will have a look.

  awest3 09:03 01 Nov 2012

only speed I can see is 100mbps

  mgmcc 09:26 01 Nov 2012

OK, it was just an idea that there might have been a problem with the speed at which network adapter and router were communicating, but 100Mbps is the correct speed.

  awest3 09:32 01 Nov 2012

Taking a deeper look at the network adapter via device manager it appears to be a broadcom 802.11g, this would suggest that it is not capable of supporting the n type router! or is my logic wrong?.

Do I need to buy a new network adapter which runs 801.11n? or is it a software update?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)