Broadband connection problem with laptop.

  AlanRodgers 17:10 24 Aug 2014

Hi. Ive recently changed my ISP from Plusnet to the Post Office. Ive got two computers, A Dell tower style and a Hi Grade laptop. I connected the Dell first, no problems. When I try to connect the laptop, it wont accept the password! It accepts the name of the router and it can see the the router on the 'Connect to a network' panel. But when I go to put the password in it wont have it, even though Im using the same password I used for the Dell (obviously). And yes Im using the correct case etc.

Ive tried disconnecting the Dell in case there was some sort of conflict, to no avail.

I phoned the Post Office, the woman said as the Dell was working, perhaps there is a problem with the laptop.

Any suggestions?


  Jollyjohn 17:49 24 Aug 2014

Puzzled as to why you need a password to connect?

The router should hold your connection to your ISP details.

Are you connecting wireless to the router, if so you need the wireless key, which will be the same for both computers and will only need to be entered once.

Any error message? Details would help.

  spuds 18:27 24 Aug 2014

What Operating System are you using?.

I have a similar problem with a laptop using Vista. It did connect once, then for some unexplained reason, it just would not again?.

I use other computer's plus another laptop, with no connections problems either with wireless or cable (XP/W7/W8). Haven't tried direct cable method with the Vista laptop. maybe I should?.

  Aitchbee 22:05 24 Aug 2014

Check your laptop, perhaps the Num Lock key is on.

  AlanRodgers 02:17 25 Aug 2014

John. You need a password -also called network (wireless) key to connect to the router, the router is already connected to the internet! The only message Im getting is the one telling me Im putting the wrong password in. I am trying to connect wirelessly. However at this moment the laptop is connected to the router via an ethernet cable.

Spuds. Im using Vista and Im connected now via an ethernet cable, I wasnt when I was trying to connect wirelessly.

Aitch. No the Number Lock isnt on. :)

  Jollyjohn 09:27 25 Aug 2014

OK. The wireless key makes sense.

Check router settings and look for "Allow new stations to connect" or similar. It may be the router is not allowing the laptop to connect.

Once in router settings you could change the wireless key to something easier to type.

  spuds 11:02 25 Aug 2014

This thread is proving interesting, because it seem to be coming back to Vista and the wireless connection. The problem I have been trying to resolve for ages, without much success.

  onthelimit1 11:14 25 Aug 2014

I know some older laptops with vista drivers won't connect to later routers with wireless security WPA2. The only way I've been able to overcome this is to use a mini wireless dongle on these laptops. To prove it, you could go into the router pages and see if you're able to turn the security off temporarily

  AlanRodgers 12:23 25 Aug 2014

Jolly John. That sounds good. You'll have to tell me how to go into my router settings!


  AlanRodgers 13:08 25 Aug 2014

Jolly John. Managed to get into my router settings via command prompt. Do you mean WPS Stations?

There is no WPS button to press on the router.

  onthelimit1 14:21 25 Aug 2014

What is the make and model. There should be a page for wireless security settings.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Best Android emulators for Mac

TV & Streaming : comment regarder Roland Garros ?