Boot-up problem

  hssutton 22:08 04 Feb 2013

Strange I've tried posting the following problem, but with UEIF Boot Problem as the title I get the we think this is spam.

UEFI boot problem

My new build is all of a sudden giving me problems at boot-up, it's not seeing my 'C' . If I go into UEFI setup the Western 500Gb sata3 I use as 'C' drive is recognised in the Storage Configuration, but is not shown in the boot screen.

To overcome the problem at the moment pressing F11 will give me the option to choose which disk to boot from. I must admit to being totally out of my depth with the UEIF setup. So any help would be appreciated.

Asrock P67 Pro motherboard

  northumbria61 22:18 04 Feb 2013

I have to confess I don't know anything about UEIF but you could take a look at this link to see if it helps enter link description here

  northumbria61 22:21 04 Feb 2013

Well I have discovered what EUIF is -

Q: What is UEFI? A: UEFI (Unified Extensible Firmware Interface) will be a specification detailing an interface that helps hand off control of the system for the pre-boot environment (i.e.: after the system is powered on, but before the operating system starts) to an operating system, such as Windows* or Linux*. UEFI will provide a clean interface between operating systems and platform firmware at boot time, and will support an architecture-independent mechanism for initializing add-in cards.

But I am still non the wiser.

  Number six 22:42 04 Feb 2013

Have you tried disabling UEFI in bios settings? This will allow your system to use the motherboard's regular bios. UEFI can be very tricky to configure correctly. (No, I don't really understand it either)

  Fruit Bat /\0/\ 22:52 04 Feb 2013

As it not a Mac, you will have a x86_64 (64-bit) UEFI 2.x firmware.

UEFI uses a special partition in the partition table called "EFI SYSTEM PARTITION" in which files required to be launched by the firmware are stored. Each vendor can store its files under /EFI// folder and can use the firmware or its shell (UEFI shell) to launch the boot program. An EFI System Partition is usually formatted as FAT32.

See here for MS explanation on GPT disks and use of UEFI

  hssutton 22:56 04 Feb 2013


Yes I've got the manual, but I'm still not much wiser. I can rectify the problem I think, by disabling all other drives other than 'C', but I didn't want to take that route as yet.

Number six

UEFI is the alternative/replacement for the BIOS. so no I cannot disable it

  hssutton 23:05 04 Feb 2013

*Fruit Bat /\0/*

I think you forgot the link. However I will do a bit of searching on EFI SYSTEM PARTITION. I cannot find any mention of this in the UEFI Setup Guide that came with the motherboard.

  Fruit Bat /\0/\ 23:12 04 Feb 2013
  hssutton 08:26 05 Feb 2013

*Fruit Bat /\0/*

I'm not sure if you misunderstood my problem as the link appears to be about partitions on a drive.

I have now got my system back up and working, but I did this by eventually disconnecting all my other drives. My 'C' being the only one connected was instantly recognized. However was hoping to sort the problem without disabling my other drives.

After a bit of searching last night I found this explanation of the UEFI Setup

UEFI Setup

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Amazon Echo: What’s the best Alexa speaker?

Kano Computer Kit Complete review: A fun DIY 'laptop' that teaches kids to code

Best pro photo editors for Mac 2018

TV & streaming : comment regarder les Jeux olympiques d’hiver 2018 ?