Boot-up hangs on USB Device Search

  daba 13:39 07 Sep 2008

Only since changing my motherboard (ASUS A7N8X to K8V) the boot-up sequence hangs here:-

Auto-detecting USB Mass Storage Devices
Device #01 : EPSON Stylus Storage
Device #02 : ...... hangs>

This only happens if the printer is turned ON.

I have an Epson RX620 with card slots, and I assume it is due to the detection of the slots in the printer, since turning the printer OFF at this point allows the boot-up to continue.

According to Epson Tech Support -
"When you start up your PC is carries out USB checks, when it gets to the printer and detects that it is there the PC will fail to start up correctly, the printer swithed on is seen as an error."

I'm not 100% happy with that explanation, as it didn't happen with the previous motherboard, same manufacturer, also an AMI BIOS.

Does anyone have an insight to this, is it something that occurs in later BIOS's, is there anything can ber done to prevent it, or do I just have to live with it.


  daba 01:07 08 Sep 2008

^^ shameless bump

surely a USB device being "switched on", ie. present, shouldn't be interpreted as an error !

can anyone help with this?

  MCE2K5 01:11 08 Sep 2008

Have you tried turning Off USB Legacy Support in the PC's BIOS.

Worked for me.

  MCE2K5 01:18 08 Sep 2008

Could there be a Memory Card in Device #02.

  daba 07:13 08 Sep 2008

MCE2K5 -
Yes, I have turned OFF legacy support. U had already thought of that possibility.

No, there is no card in any slot.

The only other thing I can think of is that I have USB 2.0 support enabled on the this motherboard, and the printer has attached to that. I could try turning off 2.0 support and see if there is a difference if you think it worth it, although I'd rather keep the 2.0 support if possible.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Illustrator Juan Esteban Rodriguez on creating highly detailed official film posters for Star Wars…

iMac Pro review

Meilleurs drones (2018)