Bluetooth adapter causes freeze on startup

  ame 14:46 10 Dec 2009

If I leave my Belkin F8T017 adapter in its USB port my pc freezes on startup at the Windows XP Home screen and I have to manually switch the pc off and restart with it removed. I have tried uninstallling the Widcomm software using Revo Uninstaller to remove all remnants but there is no difference on reinstalling - even if I stop my antivirus, firewall, anti-spyware and wireless connection before install. Another pc I have borrowed running XP Pro has no problem with the adapter being left in. Any ideas what can be causing this small but annoying glitch? The Belkin support people have not come up with any cure so far, and I have the latest drivers etc.

  mfletch 17:41 10 Dec 2009

Go to

Start>Control penal>Device Manager

unplug the Belkin adapter

Then delete its driver

Restart the computer

Insert the Belkin adapter and let it install the driver

  ame 10:45 11 Dec 2009

Tried that, mfletch, but no joy. Also tried uninstalling all the software again using Revo then reinstalling from CD without plugging in the adapter when prompted, restarting and then plugging in the adapter.....still no joy. Latest message from Belkin Support today is to try upgrading the USB Host controllers of the computer. Checked for updated drivers for host controllers using Device Manager but none available.

  ame 18:11 13 Dec 2009

Latest simplistic advice from Belkin support (in India, I presume by the names) was to start pc with adapter disconnected as it a "hard drive", to check I have enough "space on my pc" and to disable Windows firewall - despite me already telling them I had disabled all security features and the problem persists. Glad I don't have any other Belkin products giving me more serious problems! Tried starting Windows in Safe Mode, but got to line ending in ...\WINDOWS\System32\Drivers\Mup.sys before it froze. Anyone any idea how to suss out what the conflict is?

  ame 22:30 14 Dec 2009

Searched for Mup.sys and got lots of threads about BIOS problems. Judging by this click here my BIOS (Phoenix Award BIOS V6.0 PG 31 May 2005) is in need of an update! At startup I also see "W7125NMS V1.4B6 053105 13.36.59" Does this mean I have a Beta version of 1.5?

  ame 22:32 14 Dec 2009

Oops Sorry - that should be "W7125 V1.5B6 ...."

  ame 22:34 14 Dec 2009

Ohmigod "W7125NMS V1.5B6 ..."

  KremmenUK 07:03 15 Dec 2009

First thing to do under XP is to remove the Widcomm software completely.

You are far better using the Microsoft Bluetooth Stack.

What you do is plug in the Bluetooth dongle and then go to Device manager and display the Hardware ID via properties.

Something like:


Then open your bth.inf file and note the format of the other Bluetooth dongles listed.

Copy the exact format of an existing one but insert your Hardware ID in it's place.

In my case the line:

BlueCON U2= BthUsb, USB\Vid_13dd&Pid_0001

now exists in the file.

You can then set XP to automatically search for hardware and the dongle will be identified by XP and will install it.

Unfortunately this trick doesn't work with Vista.

  ame 14:23 15 Dec 2009

Thanks, KremmenUK. Latest message from Belkin is not to worry(!), as they have forwarded the issue to the next level. I'll wait to see what they say next before trying your fix. Cheers :)

  KremmenUK 14:52 15 Dec 2009

No problem.

Using the Microsoft stack is so much easier and faster.

Also very easy to implement.

Go for it :-)

  ame 14:52 28 Jan 2010

Well eventually Belkin reckoned I should replace the adapter to see if that solves the problem, even though I said it works fine on another pc. I don't think so!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Sea of Thieves Review

Dell Canvas review: the cheap Wacom Cintiq alternative

How to use iMovie for Mac, tips and more

Comment filmer l’écran d’un iPhone ?