Bios problem after adding a hard drive

  Oldchap70 13:24 12 Jun 2013


My computer is an Advent DT2204.

I added a second HD to my computer and in bios setup I made an error configuring it, chose Native IDE instead of AHCI. System shut down. So I tried resetting bios etc - no go. I had the bios chip re-flashed, started the machine. The new bios setup screen came up but I was not prepared - no keyboard or mouse plugged in! So I turned off, plugged them in and pushed the button - nothing?? So, on fiddling around I removed and replaced the jumper to reset the bios and tried again, nothing. So I tried removing the jumper again, as soon as I did, power came on and everything started, lights, fan, HDs, the lot - except there is no output to the monitor, just sits there blinking! Replace jumper, power off, replace it, power on... But no screen. OK, I shall have to take into the shop, but I just wondered if anyone has any ideas about this, or has come across the state of affairs before? I'd be very interested to know what kind of cock-up I've made!

Rich (in name only)

  Press Man 15:53 12 Jun 2013


Make absolutely sure you have the "jumper" on the correct pins, check in your manual/handbook. Turn PC off and remove the plug from the wall socket. Make sure the "jumper" is on the correct pins for normal operation. Now, remove the battery that keeps bios running its about the size of a 10 pence piece. Leave it out for about 10 minutes and then replace. Plug back in and try and get into the bios by "tapping" the del key or some other key? If you can get into the bios, then make sure your "boot order" is set correctly to boot from your HDD with the operating system on it.

  Bris 16:42 12 Jun 2013

"jumper to reset the BIOS" do you mean the clear CMOS jumper? If so its important that before you place this jumper you remove the power plug from the wall.

Also never turn on the pc with the jumper in place as this can damage the motherboard.

Hopefully this hasnt happened.

Clearing the CMOS this way restores it to the factory settings and you will then need to enter the BIOS to restore your previous settings.

With regard to AHCI, if you set this then the OS must have the necessary drivers in order to boot so if your OS on your boot drive has these drivers installed it should boot but if not its unlikely to.

  daxian 16:56 12 Jun 2013

hi all ... my first step would be to remove the new h/d cable ... the bios/cmos will not detect it and all should be ok !!!! once the pc is started /running again and you are able to access the bios /cmos,reconnect the hd and set the correct settings .

  Oldchap70 18:00 12 Jun 2013

Hi Thanks to all who replied, thank you for your time.

Unfortunately after trying all suggestions, the problem remains. It looks like curtains for the motherboard, although everything seems to be running there is still no working screen, just black and a blue light winking at me!


  Bris 18:38 12 Jun 2013

Just a thought. Have you plugged the screen into the correct socket?

If you have both a graphics card and onboard graphics plug the screen into the other one.

Resetting the CMOS may have disabled the onboard graphics.

  Oldchap70 22:26 12 Jun 2013


Thanks for your input, but there is only the vid socket, I just use the on board driver. Good thought though.

Regards Rich

  lotvic 22:49 12 Jun 2013

Probably shorted something out by messing about with it while electric was live. Be thankful it didn't short you out.

  Bris 11:50 13 Jun 2013

If its just the graphics that has a problem and you have on board graphics, one solution would be to borrow a graphics card and install that.

You may get screen output but of course that may not be your only problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

How to use 3D Touch on iPhone

Comment importer des contacts d’un iPhone à un autre iPhone ?