BIOS does not detect HDD after format

  dregn 12:05 23 Apr 2003

I wished to do a clean reinstall of Win 98 on my HDD (30GB IBM Deskstar )which was filling up so I backed up data and formatted the disk and used FDISK to create a single active partition.I booted from a Win 98 boot floppy and attempted to install the OS and got the message that 'Windows can not detect a hard drive and installation can not continue.' The boot screen showed the LS120( SuperDrive) as the Primary Drive.
The BIOS does not detect the HDD. I tried every option in CMOS; set 'Auto Detect'and finally opted for 'safe configuration'.I checked every setting in the BIOS which I thought relevant.
I ran a Drive Fitness test from IBM which came up with 'Faulty Component in Hard Drive'. I changed the HDD for a WD 80 GB disk which resulted in exactly the same situation. Still the BIOS is not detecting the driv
e ( set to auto ) the manual options in CMOS are 'grayed out' so it is not possible to enter details manually.
I disconnected the LS120 drive in an attempt to force the BIOS to auto detect the new drive but still no success. The HDD activity light is frequently lit and on starting I can hear the drive spinning up.
I am mystified - is the BIOS defective ? It was OK before I decided to format the original disk. The only thing I have not done is to run any sort of install program on the Western Digital drive. I have downloaded the Data Lifeguard program from the WD site but I was reluctant to run it because of the BIOS refusal to detect the new drive.
My system is an Abit KA7-100 m/b running a 700mhz Athlon.
I should be most grateful for any advice before I tear all my hair out !
Den Regan

  tbh72 12:35 23 Apr 2003

As you have been inside the unit..... You sould re check the ide cables are connected propery.

At the same time, jot down the HDD specification eg HEADS CYLINDERS SECTORS. Check the jumper pins on the HDD. If the LS120 is being detected as primary, then you have more than lightly mixed up the ide cables.

  cream. 12:56 23 Apr 2003

With the IBM 30 gig you may have expected a few problems if it came up with 'Faulty Component in Hard Drive'.

The nagging statement of "
The boot screen showed the LS120( SuperDrive) as the Primary Drive" Is it shown as primary master or primary slave? But you then say that it still will not be recognized when the LS120 is disconnected.

Now that you have installed the 80 gig drive and are sure jumpers and cables are correct. It may be that the bios is not up to the job. Looking from the information of win98 and LS120 drives, is the machine a few years old?

I think your best bet is to boot with the W.D. floppy and see if it will force the bios to accept the size of the new disk. Any changes you do not want can be reverted back by either setting the bios back to default or by shorting the cmos jumper on the motherboard.

  dregn 13:04 23 Apr 2003

Thanks for that tbh72
I did not think I had disturbed the IDE cables but I will check them and also take the WD HDD out and recheck the jumper pins on the drive and note the data you suggest.
I will reconnect the LS120 drive and see how it goes.
The BIOS is resolutel;y not detecting the HDD.
Further post when I have finished fiddling !

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

8 brilliant character artists speaking at Pictoplasma 2018

iMac Pro release date, UK price & specs

Football : comment regarder la Ligue 1 en direct ?