Belkin wireless problems with Windows Vista

  FearedAlYankovic 01:39 07 Aug 2007

Our main PC runs Windows Vista and is wired through our Belkin Wireless G Router. Our secondary PC runs Windows XP sp2 and is "connected" wirelessly via the Belkin Wireless G Plus MIMO USB Network Adapter.

The instruction manual explicity dictated that we were not to use the pre-install software on the included disc, as it was created before Windows Vista had officially been released.

When I originally hooked everything up, things seemed to be running smoothly. Since then, I have not been able to sustain a connection for more than a few seconds. The Windows XP box shows that the connection has excellent reception, yet nothing Internet-using is able to be pulled up on the XP machine.

I looked at a few articles, and I tried changing some of the networking settings on the Vista machine to "automatic" instead of "manual," but it doesn't seem to have made much of a difference. Is there anything I can do to get this network actually working, short of wiring the darn thing?

I'm at my wit's end. I blame Vista.

  ArrGee 01:43 07 Aug 2007

Grab an ethernet cable and wire-up both machines. Download all updates then unplug the cable.

Sounds too simple, but could do the trick (it has for me a few times)

  FearedAlYankovic 01:52 07 Aug 2007

I just got back from navigating the Belkin website, and I can't find the area where I would download updates.

I ran the software for the XP machine, but I did nothing for the Vista machine, simply because the instructions told me not to do so. Is there something I should do to the Vista machine that I haven't already done? And where do I find the updates for the XP machine?

  FearedAlYankovic 02:06 07 Aug 2007

Also, since the XP machine does report that the USB receiver is definitely receiving a signal from the router, we tried accessing a few different types of programs.

Neither IE nor any type of instant messenger program worked, but the wireless connection manager SHOWS that it is receiving a STRONG connection.

I just don't understand why the ability to connect to internet-based programs is flaky!

  ambra4 06:10 07 Aug 2007

Try this site

click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

HomePod review

Les meilleurs logiciels de montage vidéo gratuits (2018)