Belkin wifi adapter won't install driver,it is asking for notebook card

  NewestRoyWidd1 15:21 13 Jul 2012

Hello,today my Belkin 7050 wifi adapter arrived.I went through the install procedure from the cd,and when asked to plug in the adapter,I got the message asking for a notebook card,which I haven't got.It then told me that the drivers aren't installed.

The device isn't showing in device manager.I called Belkin support but all the could suggest was that the device was to try it in another computer.I am unable to do this because the communal computer needs administrator rights to install programs etc.I am currently on that pc now to send this.

I will have to top up my"3" dongle again to read replies.Please can anyone help?I am currently on limited funds and cannot affored to keep topping up my dongle

  difarn 22:39 13 Jul 2012

This is a little strange.

I believe that the adapter you have is the one that comes with a short extension lead - are you plugging the extension lead in with the adaptor or are you plugging the adapter straight into the laptop I would plug it straight into the laptop to begin with.

When you plugged the adapter in did you get a message saying that a new device had been recognised?

I would be inclined to delete the installation and start again - making sure that the adapter is plugged directly in a usb port - try a different one this time. If this fails then try to download the driver from the site I have given below.

You should be able to download the driver you need from here - from the information you have given me I think it should be the first one but plese check.

  rdave13 04:40 14 Jul 2012

I'm just wondering if it could be a conflict with your '3' dongle drivers? Never used those but I assume they have drivers and not plug and play?

  NewestRoyWidd1 10:35 14 Jul 2012

Hello difarn and rdave13;The adapter didn't come with an extension lead,it plugs directly into a usb port.I have tried all 4 ports but without success.Initially the message new device recognised came up,and that is was working ok,but then it wasn't showing at all in device manager.I am on a pc,not laptop.

I have deleted the installation several times,but still keep getting the same message asking for the notebook card and that the driver hasn't been installed.I already downloaded the driver that you pointed me to(it's version 3)but cannot use it.

Rdave 13;Before trying to install the Belkin,I had removed the '3' program,which installs just by plugging the dongle in.

  difarn 13:02 14 Jul 2012

You haven't said which OS you are using - there are various problems with vista and this article from Belkin support takes you through a "fix".

In addition I have just read a post that says this adapter is not compatible with windows 7 and has to be installed in vista mode.

Did you have another go with the wifi adapter you bought previously?

  NewestRoyWidd1 13:10 14 Jul 2012

I'm on XP Pro with SP3.Yes I've tried the previous adapter,but to no avail.

I've emailed Belkin support,but they directed me to the latest driver,which installs ok via set up,but then I just come back to the original problem of it saying it needs a Notebook Card to activate the driver.

  difarn 13:13 14 Jul 2012

Just been delving a bit deeper and found this in a blog:-

"With Belkin products in the past I have found that the download will create a folder on the c: drive in the form of C:\belkin\drivers ....

To install remove the adaptor and any existing drivers (in Device manager and make sure you select the remove files option) .. Re insert the adaptor and choose to manually install the drivers - point the selection box to the C:\belkin folder and let the install complete"

On another post about exactly the same problem the anti-virus had to be disabled before the install could go ahead.

  NewestRoyWidd1 13:23 14 Jul 2012

Just a thought;The Belkin quick set up guide shows a pc usb adapter for the item,ie a unit to put the adapter in.For use in a Notebook that unit isn't needed.Could that be the source of the problem?

There wasn't a unit shipped with the adapter.

  difarn 14:05 14 Jul 2012

This is what I mentioned in an earlier post - it's function is usually to give flexibility on where it is sited. It could have some bearing on the problem but I would be surprised.

Did you try installing the adapter without using the cd?

If you want to try this I would delete your installation, put the cd in but don't start the wizard, put your usb adapter in and see if device manager can find the driver.

  NewestRoyWidd1 16:22 14 Jul 2012

Hello,I've just tried your suggestion about putting the cd in without running the wizard,but to no avail.I got a Windows pop up saying the usb device not recognised,a usb device has malfunctioned etc.

My thinking regarding the base unit is;If one is required for use with a desktop,and there is software in that unit to recognise that a desktop is being used,when I put the adapter into a usb port,does the program think that a Notebook is being used,and therefore asks that the Notebook card be inserted in order to activate the adapter driver?

I have emailed the seller via Amazon regarding this problem and asking if there should be a base unit,and if so,can they send one to me ASAP.I 'll let you know if and when I get a reply.Please be aware that I'll be at work tonight from 6pm until tomorrow and won't be able to post again until then.

Thank you so much for your continued help and patience,it's really appreciated!


  difarn 16:34 14 Jul 2012

It won't hurt to try - I have a similar adapter and I can use it either directly into the desktop or using the usb base - yours of course may be different.

The operating instructions I have seen for your adapter definitely shows a base unit.

Glad to help - will continue to scout around

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)