Belkin USB 2.0 PCI card won't install

  kp 23:12 25 May 2003

Running WinXP with SP1 installed, Athlon 1900XP, GeForce3 Ti500 graphics, Audigy sound card.
Have tried to install Belkin USB 2.0 PCI card. The card is recognised by my PC and the drivers appear to be installing correctly then message appears saying that the card failed to install correctly. I have tried using different PCI slots, removed sound card and (redundant) modem, tried with all USB devices disconnected but still no joy. I exchanged the card for another one thinking it might be faulty but the dame thing happened again. Can anyone shed light!

Thanks. kp

  woodchip 23:16 25 May 2003

Did you let Windows wizard install the drivers or did you use the drivers on the CD you got with the card

  kp 23:21 25 May 2003


Didn't insert the driver disc initially as recommended for XP in the destruction booklet as the drivers are apparently included in SP1. Just let the wizard install. After a few failures tried with the disc in but still no joy.

  Despicable Desperado 23:22 25 May 2003

I have found that Belkin USB2 can be a pig to install. It will eventually install but you need to keep persevering. Make sure you delete all the USB drivers on your system and then let Windows redetect them - make sure your driver disk is in the drive. Keep trying. If it still fails, ask for your money back and buy a dabs value usb2 card (costs a tenner plus a small handling charge) - installs in XP with absolutely no probs

  kp 23:28 25 May 2003

Despicable Desperado
Thanks for suggestion but tried deleting all USB drivers but no luck. Getting upset now since I paid £50+ for the Belkin USB 2.0 (has 4 external USB sockets and 1 internal). Might try the Dabs card if all else fails soon.

  woodchip 23:31 25 May 2003

Go to device manager and remove all USB and restart your computer. Without the USB card in. then shut down computer pull the power plug, install the card, when you restart your computer the Hardware Wizard will say that it's found new hardware click the cancel button until the box goes away then run the CD that you got with the Card

  Despicable Desperado 23:34 25 May 2003


understand your frustration - try updating the drivers a few times. Have installed a couple of Belkin cards and the drivers just didn't want to install. Just kept trying update drivers and eventually the card said 'hello, i'm here". The dabs card has exactly the same configuration as the Belkin only £40 cheaper - sorry!!!!

  Chris.h 23:34 25 May 2003

Try loading drivers from Windows XP disk.

  kp 23:36 25 May 2003


Thanks - will try that in the morning. Will let you know.

Cheers. kp

  Despicable Desperado 23:37 25 May 2003


understand your frustration. Have fitted a couple of Belkin cards but the drivers just didn't want to install. Kept updating the drivers a few times and eventually the card popped up and said 'hello, i'm here'. The dabs card has exactly the same configuration as the Belkin only 40 quid cheaper - sorry!!!!


  Despicable Desperado 23:39 25 May 2003

Apologies for double entry - site said a prob had occurred so presumed the first post failed

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Majority of illustrators don’t earn enough to live from, new survey shows

iPhone X problems

Word gratuit : comment télécharger le logiciel de Microsoft ?