Bad Windows Updates?

  [DELETED] 20:21 11 Apr 2006

First of all let me si Hi to everybody. After nearly 8 months of not being much near a computer I am finally getting back into the swing of things. I have had to start a new account thought because I couldn't remember my old account (AcydByrn) details. Now for the problem.

I have just recently re-installed WindowsXP home ready for getting my new net connection installed. I got everything workings as it should (even installed anti-virus and firewall pre-emptivley) and things were all fine. Anyway, the day my net was up and running the first thing I spent a few hours doing was getting all the latest updates and 'definitions' (anti-virus, Spybot S&D etc). Then yesterday I tried to install a new belkin 4 port hub I bought. The usual 'Add new hardware' wizard popped, reported a new 'usb device' up and proceeded to search for drivers. It then failed with the message:

"The hardware was not installed because the wizard cannot find the necessary software"

I first headed to Belkin's site for some support but found none. After several tries I thought it might be broken so returned it and got an exchange. The same thing happened. Then, not long ago I tried installing a second-hand iPod shuffle I bought from a friend, plugged it in and...

Nothing. That isn't detected by iTunes or WindowsXP (it does work, we tried it on my friends computer and its been updated with MY songs whilst plugged in)

But the same thing happens with the hardware wizard. I have been mooching around the net to see if I can find anything, particularly about the iPod, and some people have mentioned a possible bad windows update. This seems theoretically correct as a lot of people seem to be having trouble with shuffles and it all seems to be within the last few weeks.

So could it be? Failing that does anybody have any ideas?

Note: I have all the latest drivers for my motherboard/chipset; MSI KT4V.

Help really appreciated,

  Stuartli 21:19 11 Apr 2006

Have you checked Device Manager>USB Controllers?

You should see the word Enhanced if the USB drivers are installed.

You may have to install the drivers from the manufacturer's website or the hub's CD-ROM if you got one.

I presume you have SP2 installed?

Also see

click here

  Stuartli 21:20 11 Apr 2006

I'm referring to USB2.0 drivers although it should also work with USB1.1 (just a lot slower).

  [DELETED] 21:28 11 Apr 2006

With the Belkin equipment did you try with the Belkin CD in the drive? I installed a Belkin UPS recently and following Belkkin's instructions didn't work and Windows gave a no drivers found message the same as yours. I put the CD in the drive and tried again and hey presto!

  [DELETED] 21:42 11 Apr 2006

The only listing that contains enhanced is "Standard Enhanced PCI to USB controller"

I dont have any PCI-USB cards installed, all built into the mother board.

The Hub is showing as Other Devices-->USB Device (with the yellow question mark.

Yes, I am using SP2.

VoG, the hub didn't come with a hub, just a very short (4 pages, 2 pages the EXACT same) manual.

Stuartli, I'll try that link right now.

  [DELETED] 21:50 11 Apr 2006

P.S. Right clicking the advanced controller and selecting properties-->advances states that 10% of the controllers bandwidth is used

  [DELETED] 23:00 11 Apr 2006

I just tried installed some Kodak EasyShare software for my Mums camera (She's useless with technology in general!), the software installed and I duely restarted the PC. Plugged the camera in and turned it on...and...same message!!

I don't know bout you Guys and Gals but it appears as though ANY new USB device cannot be installed! Or at least thats what I'm thinking.

What would cause a problem like that?

  [DELETED] 23:12 11 Apr 2006

Can you go to Device manager and un-install the usb devices showing the yellow card then re-boot and see if OS finds them

  woodchip 23:23 11 Apr 2006

Two things you can try. First may seem stupid, but try it. Turn off your Computer and pull the mains plug out of wall socket and then press anf hold the start button on the computer for about 30 seconds. Restart computer and try USB. If no go/

Try going to Device Manager click the + by the USB and then uninstall all USB starting from bottom, restart and allow all USB to reload the try you USB again

  [DELETED] 23:28 11 Apr 2006

well, I have already tried uninstalling the devices and restarting to no avail, but get this...

I have just uninstalled SP2 and the hub has been configured!! And now the iPod works aswell!!!

Go figure. I'm going to now re-install SP2 and see what happens.

Woodchip, why hold the power button for 30 seconds after yanking the mains? Your right, it does seem a bit odd.

  woodchip 23:33 11 Apr 2006

It discharges caps on the board

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Amazon Prime Day 2018: Best Deals & Launches

Say aloha to the summertime vibes of artist Kim Sielbeck

The best Amazon Prime Day Apple deals 2018

Les meilleures séries Amazon Prime Video (2018)