Bad Seagate Desktop USB 3.0 driver

  Monte L Chalmers 02:51 22 May 2018
Locked

I have a bad driver in my Desktop USB 3.0 and my Windows 7 no longer "sees" it so that I can see the contents. At one point checking the control panel device manager, I found the drive and ran a test that showed me the trouble is with the driver. Windows said it would try to replace the driver, nothing has worked. I went to Seagate for help and didn't find any. There Seatools was no help because it also doesn't see the drive. All I think that I need is a replacement driver. But how do I do it??

  Fruit Bat /\0/\ 18:39 22 May 2018

make and model of PC? download the USB3 driver from the manufacturers web site then uninstall it in device manager and run the new driver.

  Monte L Chalmers 01:46 23 May 2018

Thanks for the reply, FB. But your answer is my problem. Not able to get a driver from Seagate. I found a section called Contact Us, which usually provided an email address to ask for help. But not Seagate. I was offered to ask a question. My question was: "How can I download a replacement driver for my Desktop USB 3.0?" and there answer: "no result found. Try rewording your question." .... This is why I've tried coming here for help.

  Menzie 02:21 23 May 2018

Hard drives and flash drives don't have any special drivers. They show up by device name when connected but they all use a standard driver built into Windows/Linux/Mac OS/ Xbox/ PlayStation, etc.

What happens when you connect the drive to an available USB 2 port? Does it show up then?

Do you have any problems with any other devices connected to your USB 3.0 port? If so then the suggestion above to reinstall the drivers for your motherboards onboard USB 3.0 chipset will be the best course of action.

  Monte L Chalmers 03:41 23 May 2018

Yes, Menzie, when the drive is connected or disconnected, there is the usual audible connect/disconnect sounds. But there is no video symbol for the drive showing up in the computer display of internal and external drives. My Windows 7 is not "seeing" the Seagate so to speak. But something is getting through for there to be the audio. All I need is a driver and my Windows 7 should be able to find it. But all that happens is a long time with the moving circle. An an eventual notice that nothing was found. Seagate would love to sell me a new drive. But It seems the old one is working - I still gets notices on computer startup that backup has been successful. Unfortunate I can't "see" it.

  Fruit Bat /\0/\ 09:52 23 May 2018

It won't be a driver from seagate it will be a driver from the motherboard manufacturer for the USB 3 controller on the motherboard.

  wiganken2 12:41 23 May 2018

Have you tried USBDeview (see click here ). Nirsoft states "USBDeview also allows you to uninstall USB devices that you previously used, disconnect USB devices that are currently connected to your computer, as well as to disable and enable USB devices." After doing this I understand that restarting your PC causes Windows to reload the default USB drivers to fix the problem.

  Monte L Chalmers 14:43 24 May 2018

Thanks for the info, wiganken2. I downloaded USBDeview and it seems to at least somewhat work. I quickly found the serial number of the USB3.0 and did a delete which caused the serial number line item to disappear. Then selected an install of the item which brought up that a driver was being looked for...... but the result was the SAME!! No driver found. The driver is the issue.

  Fruit Bat /\0/\ 14:57 24 May 2018

Read my two posts you need a USb 3 controller driver form the manufacture's web site

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 6T McLaren edition costs more and charges faster

Climate change, War and #MeToo: 'Ugly Truth' Christmas jumpers show the dark side to modern life

New Apple Products 2019: Predicting the new Apple products coming soon

Samsung Galaxy S10 : date de sortie, prix et autres rumeurs