autorun problem windows xp

  ©®@$? 20:33 19 Feb 2004

have windows xp, and all my cd's/dvd's don't autoplay ,the contents of the drive load up instead..

i have changed the autoplay settings back to default, wher eit prompts each time, made no difference, i have run a regedit fix, to restore autorun, still only loading the contents of the cd up..

  ©®@$? 20:38 19 Feb 2004

seems to me that the volume isn't being checked for the autorun.inf file

i am also logged in as a administrator..

this normally happens when a limited user is logged in, but it isn't the case for me

  powerless 20:40 19 Feb 2004

So you've looked at >> click here << ?

  ©®@$? 20:55 19 Feb 2004

cheers powerless

i have ran the autorun repair tool from ms, and it has fixed one error it found for my dvd drive, but cannot resolve a problem with the cd rw!

i'll keep you posted in the middle of trying to sort it.

this is the log for my cd rw drive

it couldnt resolve it

utoFix [V5.2.3790.67]
Time [2004-02-19 20:57:56]
Microsoft Windows Version [5.1 (Service Pack 1) <2600>]

Test [The Shell Hardware Detection service is running.] - Instance [N/A]:
Result [AutoStart Setting]: OK
Result [The Shell Hardware Detection service is running.]: OK

Test [Policies] - Instance [F:\, Drive Type: 5]:
Result [HKCU\...\Policies!NoDrives]: OK {Absent}
Result [HKCU\...\Policies!NoDriveAutorun]: OK {Absent}
Result [HKCU\...\Policies!NoDriveTypeAutorun]: OK {Present}
Result [HKLM\...\Policies!NoDrives]: OK {Absent}
Result [HKLM\...\Policies!NoDriveAutorun]: OK {Absent}
Result [HKLM\...\Policies!NoDriveTypeAutorun]: OK {Absent}
Result [Driver level policies]: OK {
HKLM\...\Services\cdrom!Autorun (Present) <Allows>
HKLM\...\Services\cdrom\Parameters!Autorun (Absent) <Allows>
HKLM\System\CCS\Enum\...!AlwaysEnable (Absent) <Not set>
HKLM\System\CCS\Enum\...!AlwaysDisable (Absent) <Not set> }

Test [Drive Notification] - Instance [F:\, Drive Type: 5]:
Result [Legacy Notification]: OK
Result [AutoPlay V2 Notification]: Problems {
Service (Fired)
Shell (Deaf) }
>> Repair << [Autoplay V2 Event]
Step: Deleting ShellHWDetection LaunchPermission (HKEY_CLASSES_ROOT\AppID\{B1B9CBB2-B198-47E2-8260-9FD629A2B2EC}!LaunchPermission)
Result: The wizard ran into problems while trying to delete this registry value (HKEY_CLASSES_ROOT\AppID\{B1B9CBB2-B198-47E2-8260-9FD629A2B2EC}!LaunchPermission).

>> Required action: The wizard found problems but cannot fix them -> None

  ©®@$? 20:59 19 Feb 2004

an example of my problem

i ahve just put black hawk down in the drive,it spins up but not even the contents show up this time, i goto the drive and right click and select autoplay

i get this message

windows cannot find installer.exe

this program is needed to open this type of file!

i do recall when this problem first arrose, was that it sais no cdstart.exe, which is a new one to me!

think it is just messed up, xp has been working along time on this computer and must be wanting to throw a tamptrum..

  ©®@$? 21:03 19 Feb 2004

you see where the wizard ran into the problem here

The wizard ran into problems while trying to delete this registry value (HKEY_CLASSES_ROOT\AppID\{B1B9CBB2-B198-47E2-8260-9FD629A2B2EC}!LaunchPermission).

well i have deleted the key that ti cldn't and i'm going to try again

  ©®@$? 21:16 19 Feb 2004

nope made no diff, the repair still couldn't resolve it. so i restore the reg key i deleted, right clicked it and selected permissions, think ing i was onto something, there permission for my name wasn't selected so i selected them,ran the tool again but still the same error!

havn't rebooted yet,but doubt it will make much difference

going to look at your link again powerless, im sure they are all checked out, but will double check now!

  ©®@$? 21:19 19 Feb 2004

all present and correct

typical innit

  ©®@$? 21:42 19 Feb 2004

solved it!

that link you gave me powerless, i checked the settings according to the link and it said about


You must set the hexadecimal value to 91 to enable the AutoRun feature

as mine was set to this i started looking else where...

didn't get any further and ended back at that registry key


i right clicked it modified the binary to 0000 95 00 00 00

and guess what both drives now work!

so i wonder why ms say about it being set to 91 to enable auorun, which mine was but it certainly wasn't working, altering it to 95 00 00 00 did the trick!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

See iconic duo Smith and Foulkes' epic animation for the BBC's Winter Olympics coverage

iMac Pro review

Idées cadeaux pour geeks et tech addicts