Autorun on four drives not working

  swapper 08:19 08 Jul 2004

I have two PC, one still in warranty, over the last few weeks I have developed the problem where none of the four drives DVD,DVD/RW, DVD Rom and CDR/RW (two on each PC, will run on AutoRun.
I have tried almost everything, bought RegMechanic, used RegScrub, to no avail.
With AutoFix I have got the following result for one drive, but it applies to the other three,
can anyone see the problem please?

What I know I have done is install/uninstall both PowerProducer 2 and Nero5 if this helps

AutoFix [V5.2.3790.67]
Time [2004-07-08 08:04:02]
Microsoft Windows Version [5.1 (Service Pack 1) 2600>]

Test [The Shell Hardware Detection service is running.] - Instance [N/A]:
Result [AutoStart Setting]: OK
Result [The Shell Hardware Detection service is running.]: OK

Test [Policies] - Instance [F:\, Drive Type: 5]:
Result [HKCU\...\Policies!NoDrives]: OK {Absent}
Result [HKCU\...\Policies!NoDriveAutorun]: OK {Absent}
Result [HKCU\...\Policies!NoDriveTypeAutorun]: OK {Present}
Result [HKLM\...\Policies!NoDrives]: OK {Absent}
Result [HKLM\...\Policies!NoDriveAutorun]: OK {Absent}
Result [HKLM\...\Policies!NoDriveTypeAutorun]: OK {Absent}
Result [Driver level policies]: OK {
HKLM\...\Services\cdrom!Autorun (Present) Allows>
HKLM\...\Services\cdrom\Parameters!Autorun (Absent) Allows>
HKLM\System\CCS\Enum\...!AlwaysEnable (Absent) Not set>
HKLM\System\CCS\Enum\...!AlwaysDisable (Absent) Not set> }

Test [Drive Notification] - Instance [F:\, Drive Type: 5]:
Result [Legacy Notification]: OK
Result [AutoPlay V2 Notification]: Problems {
Service (Silent)
Shell (Deaf) }
>> Repair [Autoplay V2 Event]
Step: No steps to take.
Result: This AutoPlay setting cannot be fixed. Either the device is malfunctioning, or the wizard cannot determine the problem.

>> Required action: The wizard found problems but cannot fix them -> None

  User-312386 08:27 08 Jul 2004

double click My Computer

Right click the drive you want to autorun, select properties and then the autoplay tab.

Now make sure the little dot is in "promt me each time to use an action"

If that dot is there allready, click on the "select an action to perform", click on apply and then close the box.

Now go back and then add the little dot in "promt me each time to use an action" and press apply

see if that helps

  swapper 09:05 08 Jul 2004

thanks madboy3, tried that as the first option.

I don't know why I think this way, but I am sure that either Nero5(reinstalled) or PowerProducer2 has interfered with the registry of something, things were o.k. before .

That is why I have used Autofix, RegMechanic and Regscrub.
I know that all the drives are working o.k. because they run o.k. manually.

  swapper 13:14 08 Jul 2004


  VoG II 13:18 08 Jul 2004
  swapper 16:58 08 Jul 2004

Thanks VoG, I have tried this, you will notice that I have enclosed the printed result of that test, a third of the way down my query, I am hoping that someone can look at that result and tell me what my problem may be :-((
As I have said, I am beginning to think it is something to do with reinstalling Nero5 or PowerProducer2 on two different PC and getting the same problems with their CD/DVD/CDr/RW and DVD drives.

  swapper 18:43 08 Jul 2004

TIA :-))

  swapper 18:44 08 Jul 2004

TIA :-))

  swapper 22:14 08 Jul 2004

help please?

  vinnyo123 05:01 09 Jul 2004

cd auto run

If auto run is not working in win xp go to>start>Run the Registry Editor (REGEDIT.EXE).
Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom.
Double-click the Autorun value(right side of screne), and type 1 for its value. (If it's not there, create it by selecting Edit -> New -> DWORD Value, and typing "Autorun" for its name.)

PS nervous about registry just Navigate to the registry key and check the value data you have 1 is enable and 0 is disable ,change as you wish it to do.Just check the value if you are worried about the registry as I said 1 or 0 is to enable or disable.If you have any problems I can get you a tool called tweak ui that would adjust registry for you ....

as always back up registry!
Let other members comment on this before trying but should be safe as value is only on off!

  swapper 09:35 09 Jul 2004

thanks vinnyo123, I checked the registry as you suggested and the value is 1.
What I did notice underneath the "Autorun Reg D word - 0x00000001(1)" was
"AutoRunAlways disable etc." with the names of my two NEC and Pioneer drives,
that seems to be telling me that they are permantly disabled for Autorun" what do you think?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

WWDC history: Apple's product launches since 2005

Comment importer des contacts d’un iPhone à un autre iPhone ?