Attachment has no extension once saved - why?

  AroundAgain 22:05 15 Sep 2013

Not a big problem but it irritates me ;)

I regularly get a PowerPoint file as attachment from a friend (we do monthly posters for a cat charity) but when I have saved it, it hasn't saved the .ppt extension. Consequently, I then have to give it the extension of .ppt

The attachment actually arrives (via Thunderbird) and does show the .ppt extension, so when double clicked, it suggests opening with PowerPoint.

So, something changes this when I click on Save. It only happens on attachments from this particular person. I don't remember getting ppt files from other people so can't say whether it's only this friend or all senders.

Please, can anyone suggest what 'tweaks' are needed in either my machine or my friends?


  lotvic 23:41 15 Sep 2013

Try sending yourself a .ppt file and then saving it (in a different folder to the original one). This will test if it is you.

  wee eddie 04:00 16 Sep 2013

I'm probably out of line here but have you got Windows set up to Display Extensions?

  AroundAgain 09:17 16 Sep 2013

Good morning lotvic and wee eddie

Thanks for your replies.

I've just sent a ppt to myself, to two different accounts and both, when saved, are without extension. So, it's obviously something in my machine.

Other files (as far as I can remember) save with their extensions.

So, I'd be pleased to hear any suggestions as to how to rectify this.

Wee eddie, I'm not sure of the answer to your question. If you could explain how to check this, I'll do so.

Thanks, as always J

  Secret-Squirrel 09:22 16 Sep 2013

AroundAgain, following on from Eddie's hunch, what happens when you double-click on the saved PPT attachment? Does it open fine or do you get an error? If you do then then let us know what it says.

  Mr Mistoffelees 09:25 16 Sep 2013

Open control Panel then choose Folder Options followed by View, then look down the list and untick Hide Extensions For Known File Types and apply.

  wee eddie 09:26 16 Sep 2013

Lifted this from Windows Support

Show or hide file name extensions

A file name extension is a set of characters added to the end of a file name that determine which program should open it. For more information, see File names and file name extensions: frequently asked questions.

Windows hides file name extensions, but you can choose to make them visible.

To show or hide file name extensions

Click to open Folder Options.

Click the View tab, and then, under Advanced settings, do one of the following:

To show file name extensions, clear the Hide extensions for known file types check box, and then click OK.

To hide file name extensions, select the Hide extensions for known file types check box, and then click OK.

  AroundAgain 11:24 16 Sep 2013

Hey, well done guys! :) You've solved it !!!

Secret-Squirrel - when I d/c on the saved file, the window asking for which program to open with showed.

Then, I followed the instructions to 'untick' hide extensions, as given by both Mr Mistoffelees and wee eddie, and now it saves as a ppt file and opens on d/c

So, it has been my machine doing this, and not my friend's!!! :) Strange that it's only been ppt files that haven't saved with their extension. Still, now it's sorted.

I am really very appreciative of all your help. Not sure who to put the tick next to as both Mr Mistoffelees and wee eddie have the solution. I think I'll tick wee eddie's, for no better reason than it's the last one ;) Please don't take offence Mr Mistoffelees ;)

BTW, wee eddie, I did try Google-ing but couldn't come up with a satisfactory link so I probably didn't use the right keywords. Thanks for finding it out for me, though

Thank you, guys (or gals ) very much for this help :) J

  Secret-Squirrel 13:43 16 Sep 2013

Thanks for the feedback :)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

There's a new Gradient tool coming to Adobe Illustrator

Best Android emulators for Mac

Les drôles de questions à poser à votre assistant Google Home