ATI Radeon 9800pro 256mb only recognised as 16mb

  Radix Lecti 21:49 18 May 2006

Hi all, I've had this card since it came out and it has served me well until now.

For some reason, when running games, it's only being detected as a 16mb card and therefore many games are refusing to run (literally, with a message to say so).

I'm running the latest CATS , have been through the uninstal...clean...reinstal procedure, but no difference.

When running the demo for Rise of Legends for example, the game tells me that AGP texture acceleration is currently turned off (which it's not).

Could this be a hyperion 4 in 1 issue?

Any ideas?

  aca 22:11 18 May 2006

What chipset do you have on your mobo. I had a load of problems with conflicts between a via chipset (KT400) and my 9800 pro (went through considerable pain and troubleshooting).

(drivers/4 in 1s/reformat/directx/ etc etc)

Although I didnt get misread of memory. Have you checked the AGP settings in your bios?

There are some known issues with some of the older via chipsets and some of the 9600-9800 cards.

I solved my problems by a bios update.

  Radix Lecti 00:16 19 May 2006

I have a Gigabyte GA-7NNXP mobo with the latest BIOS.

Can't see it being this, as the 9800pro has worked with it for 3 years or so now.

Checked AGP settings in BIOS, all 'go' there.

  GaT7 01:13 19 May 2006

What does a DirectX diagnostics test show?

Start > Run, type dxdiag. Click OK. Click on the Display tab. Is the g'card memory showing up correctly? Are ALL DirectX features enabled? Click the Test DirectDraw & Test Direct3D buttons - do they run OK?

If there are problems reinstall DirectX - to download click here. On second thoughts, reinstall DirectX even if there aren't any problems, then reinstall the drivers.

Other things to try:-

- if it's a HARDWARE problem:

* Check to see if the card is overheating with this tool click here.

* Uninstall drivers, disconnect power cable, open PC case, remove card, clean connections/slot & reseat. In addition, check that it's getting the power it requires (if applicable). Use another power cable if possible. Power on & reinstall drivers.

* Try another or similar g'card if possible (borrow from a friend?), &/or the same card in another PC. Try another power supply.

- if it's a SOFTWARE problem:

* Try a sfc /scannow click here.

* Try older drivers - sounds deluded, but it has worked for me (to solve a different problem).

<< Last resort 1: WinXP Repair Install? click here.

<< Last resort 2: Reinstall Windows afresh?

<< Last resort 3: New g'card? / mobo? / power supply? Hope NOT!

Good luck, G

  Radix Lecti 09:43 19 May 2006

Here's what I've found this far.

All card info in dxdiag seems to be present and correct, however I have "N/a" shown for 'Approx. Total Memory'.

Direct Draw Acceleration is detailed as being unavailable (and the 'Enable' button is greyed out). This also goes for AGP Texture Acceleration).

The DirectDraw test worked fine, however the Direct3D test failed on the first part ("Test failed at step 8 (Creating 3D device): HRESULT= 0x8007000r (Out of memory)".

The Direct3D 8 and 9 tests worked fine.

Tried a reinstall of DX, but no difference.

Also installed ATI Tray Tools, however it has grayed out any check boxes relating to monitoring GPU temperature :(

Will try the physical hardware route later...

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HP Envy x2 review: Hands-on

Iconic New York graphic designer Milton Glaser on his uplifting new subway posters

New iMac Pro release date, UK price & specs rumours

Comment suivre le parcours du père Noël ?