ATAPI driver boot problem with xp

  Hairy Yeti 02:38 19 Jun 2005

This is an long ongoing annoyance which has just become a serious problem.

XP PRO SP2, One DVD reader (Hitachi HL-DT-ST DVD-ROM GDR8162B), One DVD/CD single layer burner (Sony DVD RW DW-U18A)

For ages now my optical drivers have not installed properly on boot up. Symptoms are :

1 When booting sufficient driver functionality exists to boot from CD.

2 After booting drives are shown in device manager but are totally n/g. ie exploring a disc gives "device not ready".

3 Using device manager to "disable" then "enable" the drives restores full functionality.

This was only an inconvenience until now as I normally use the ACPI "suspend to ram" feature and so avoided reboots except for updates/installs etc.

However, I use the m/c for editing DV footage and have just removed OEM versions of ULEAD and PINNACLE and installed ROXIO Media Creator 7.0 and this package seems to do its hardware detection on bootup.

The initial problem after ROXIO install was the PC kept rebooting itself (Suspect ROXIO didn't like the hardware drivers).
Inhibiting the 'auto reboot on error' showed an RDR_file_system error. I corrected this by removing a registry key at "HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control/Class/{4d36e965-e325-11ce-bfc1-08002be10318} and deleted the REG_MULTI_SZ data type UpperFilters. Got this from a MicroSoft newsgroup thread for a different optical problem.

So now back where I started (have to 'disable' and 'enable' to get functionality) EXCEPT because ROXIO hasn't seen the drivers on boot up it denies that I have a burner. DeepBurner works fine.

Anyone out there who can save my sanity?

  Hairy Yeti 19:59 19 Jun 2005

I forgot to say - if I try to put the m/c into standby after a bootup without 'disabling' + 'enabling' the drives I get:-

"The device driver for the 'HL-DT-ST DVD-ROM GRD8162B' device is preventing the machine from entering standby. Please close all applications and try again. If the problem persists, you may need to update this driver."

If I then 'disable' and 'enable' just the GRD8162B the error message appears but refers to the sony drive.

Anyone know which part of the startup sequence handles the ATAPI device detection and drivers?

  Joe R 20:10 19 Jun 2005

Hairy Yeti,

Have you tried right clicking on each device in my computer, select, properties-record and tick the "enable cd recording on this drive".?

  SEASHANTY 20:12 19 Jun 2005

Try updating the driver in Device Manager. From MY COMPUTER right click and select Properties then Hardware then device manager. Double click on the drive(s) and from the window try "update driver".
You could also try an uninstall and reinstall from here. Just a suggestion - it may not work.

  De Marcus 20:17 19 Jun 2005

Most consistent cd/dvd drive errors that keep cropping up I've found to be down to corrupt IDE drivers or software uninstall the ide channel the drives sit on and reboot, let the os re-install the drivers and give it another go.

  Hairy Yeti 20:45 19 Jun 2005

Thanks for your responses

Joe R

The Hitachi is a reader only but the Sony burner doesn't give me that option. Deepburner still works though. Interesting


I have tried this several times and the word is "The best drivers are already installed". I have just noticed that the provider is Pinnacle. More on this below.

De Marcus

I have tried this several times also. Easy to do as I'm using SATA HDD's.

Re Pinnacle - When I first built the PC (18 months + ago) Pinnacle Instant CD/DVD suite was included with the burner. It cause problems (can't remember what now) so I removed it. I do remember that one of the things it did was to create a virtual drive (visable in explorer) for drag'n'drop packet burning. It has obviously messed with the ATAPI base drivers. I'm going to reboot to safe mode and try uninstalling the devices there.
More soon. Thanks again guys.

  Hairy Yeti 21:32 19 Jun 2005

OK. Booted to safe mode and uninstalled both optical drives and both IDE channels.

Rebooted and watched XP install the hardware in the order it appears in device manager Hitachi - Sony - Primary IDE - Seconary IDE.

Put a data cd (Roxio install) in the Sony and hey presto the icon changed and the autorun fired up. Cancelled the autorun and tried standby - OK. Rebooted and tried standby and got the old

"The device driver for the ...... If the problem persists, you may need to update this driver"


Have since discovered if I have a disc in a drive (either one) when the machine boots I can explore it, but I have to eject the disc and reinsert it to get the icon. If there is no disc in the drive on bootup it will not function (device not ready) unless I 'disable' + 'enable' it.

The driver provider for both drives is still Pinnacle. I suspect this is significant.
I am getting close to considering deleting every instance of "Pinnacle" I can find and picking up the pieces afterwards.
If anyone has a less 'shotgun' method I will kiss their feet! (Virtually of course)

  Joe R 21:40 19 Jun 2005

Hairy Yeti,

what motherboard and chipset are you using.?

XP should install its own drivers for these devices.

  Hairy Yeti 23:19 19 Jun 2005

Hi Joe R

Sorry I was a while. Been trying different things and searching the Pinnacle site.

My mobo is an EPOX 4PDA5 with Intel 865 PE (Springdale PE). CPU P4 3.2 HT .

The pinnacle site doesn't seem to offer any exacly relevant FAQ, but if you have trouble with Pinnacle products not seeing your burner you should
1 - uninstall all burning s/w
2 - delete the reg entry "REG_MULTI_SZ data type UpperFilters" as I did at the begining.
3 - Also the reg entry "REG_MULTI_SZ data type LowerFilters"
4 - Then run a file "C:\WINDOWS\system32\PSDrvCheck.exe" to fix any problems
5 - Then reinstall all s/w removed in step 3

Well I've done the first 4 steps but as my m/c still won't go into standby I haven't bothered reinstalling the s/w yet.

I tried submitting a question to Pinnacle's Knowledge data base , but when I attempted to create an account it insisted I already had one but refused to email me my details. Bad day.

Think I'll quit until tomorrow eve and have a drink now.

Thanks again for your efforts.

  Hairy Yeti 22:24 30 Jun 2005

This is still driving me nuts.

I have a very slow dialog on-going with Pinnacle support (one email per working day). 10 exchanges so far.

I'm hoping that if I update this tread someone will be able to beat them to the punch. I would love to tell them.

So far we have established that if install the CD in the usual fashion I have to disable/enable 3 optical drives in Device manager to achive APCI standby mode. 2 of the drives are physical and the third is a virtual drive created by the install for use in drag-n-drop UDF burning.

However if I copy the install CD to my HDD first I only have to disable/enable the physical drives.

Not much to show for 2 weeks effort.

In the course of this process I was pointed to a cute reg cleaner.
click here
Anyone know of a better one?

I hope someone can rise to the challenge so we can whip 'em.

  De Marcus 22:32 30 Jun 2005

CCleaner has a reg cleaner utility click here
do you get a code 31 at the and of any error messages?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

Best Keyboards for Designers & Artists

What to ask Siri on the HomePod

Meilleurs VPN (2018)