ATA Channel disappeared

  tadpole1 20:36 14 Mar 2009

I finally decided to update my drivers today but stupidly tried to install several at once. When I rebooted I got the message that the ADA Channel 0 (plus one other) still needed to reboot to install. After several reboots I was getting the same message and as I couldn't rollback the driver (as it hadn't installed) I decided to do a system restore to this morning. That seemed to work but then I got the same message about the ADA channel trying to install. When i tried to reboot again I got a blue screen and the startup repair suggested an issue with a driver. I did another system restore to the earliest point available and managed to get back into windows. When I checked my device manager the ADA channels that were there before have gone.

I have no idea what these channels do but I want to try and solve the problem before I shut down my laptop again.

  Stuartli 23:49 14 Mar 2009

Try reinstalling the motherboard drivers.

  tadpole1 08:25 15 Mar 2009

How do I do this. I've using DriverMax to update my drivers and I'm going through these one at a time at the moment but I don't even know what the motherboard is called. I've tried looking on the Acer website but again I'm not sure what I'm looking for. I've got an Acer Aspire 5920G running on Vista

  Fruit Bat /\0/\ 09:46 15 Mar 2009

XP drivers Aspire 5920 click here

lots of others click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

HomePod review

Comment regarder les Oscars 2018 ?