Asus mobo won't recognise sata drive

  Andknig 22:26 26 Jul 2004

Hi. I am trying to upgrade my ATA HDD to SATA. The plan was to connect my new SATA hdd to my exsisting system and then use Norton Ghost to copy to new hdd, remove the old hdd and voila??

OK, major flaw? Can't get my system to recognise the new hdd. The drive is connected to the mobo with SATA cable,the jumpers are in the correct position, on booting i can't get BIOS to find the new hdd. So, therefore the 'new hardware wizard' doesn't activate. I have managed to install drivers, but apparently they are unsigned (Silicon Image SiI 3112 RAID controller), and are also marked with a ! in device manager.

I have read numerous threads on this, and the majority of answers are for setting up a new system. I have tried auto detect in BIOS, but with no joy.

System details: Win XP, ASUS a7n8x deluxe MOBO - pcb2.0, 2600+, maxtor40gb ATA100 HDD, 1GB ram. The new SATA drive is Samsung spinpoint p series 80gb.

Don't understand !


  Chegs ® 01:46 27 Jul 2004

The problem is,BIOS doesn't "see" the SATA.You need the Si3112 driver installed correctly,as yours has an (!) beside it,the system will never be able to use it.None of the Si3112 drivers are XP certified,but they still work as they should.During bootup(with the driver correctly installed)you should see a script saying something similar to "SATA Link Controller...." and below it "Primary...(description of SATA drive)"I am midway thru a large d/l,but once its done I will reboot my PC and give you the exact wording of the screen prompt.

  flyingpeterpan 02:08 27 Jul 2004

I don't think you have installed the driver correctly, it looks like you installed the driver on the old drive, normally you have to install this controller while installing OS on the new drive, then press F6 soon after SETUP begins .

  Chegs ® 02:42 27 Jul 2004

The F6 option is only to install the OS onto a SATA drive,I am presently running my "old" IDE hdd with the SATA controller for my SATA drives(which unfortunately have failed,both within a week of each other)installed AFTER I had reinstalled the OS.To install the SI controller,I simply used the mobo driver CD.

  flyingpeterpan 03:14 27 Jul 2004

I am aware of your unfortunate, I'd never run SATA controller on an IDE drive to control other SATA drive yet, the SI controller from the MOBO CD which I normally used as GUI (control panel) to manage my 4 SATA drives set up as raid 10,but I still think Andknig's problem was the F6 option, do you agree?
I think we should start a new thread about SATA drives and RAID, anyway this is Andknig's thread,isn't it? :o)

  Chegs ® 03:45 27 Jul 2004

Right,just been and refreshed my brain.The exact wording is....

Sil 3112A SATALink Host Controller BIOS Version 4.1.36C

Copyright 1997-2002 Silicon Image,Inc

Primary Channel.....(Your HDD)

Secondary Channel.....(Your HDD)

So,I was wrong to say its not detected in BIOS as this IS a BIOS,only not the motherboards BIOS which doesn't detect SATA drives.If your hdd isn't detected by THIS controller,then you either haven't installed the driver correctly or your SATA drives failed.The failed option isn't likely,so its left to incorrectly installed driver,hence the (!) in Device Manager.

  Satmansq 09:16 27 Jul 2004

I have the same board and suffered the same problem, final solution was no drivers required, just needed to set boot device to SCSI. Once this was done no further problems.

  Andknig 09:21 27 Jul 2004

Right, I have uninstalled the controller and driver. Chegs - can you tell me how you installed your SATA driver/controller? Last time I installed the driver and SATALink GUI from the MOBO CD, but if I looked under device manager no option for SCSI/RAID existed. The method I used before (which resulted in ! next to controller) was to add device manually under 'add hardware' as the 'wizard' could not detect new hdd.

Sorry peterpan, is the F6 option for setting up a new system only? My idea was to change my IDE ATA100 to SATA by the simple method (@*&#!!!) of just plugging in the new drive and copying my old hdd to it, then removing old hdd.

  temp003 09:31 27 Jul 2004

When you install the driver in Windows, you should not select the GUI folder. That folder is for installing the RAID drivers.

You should browse/point to the folder which contains the GUI folder on the motherboard CD (that is, one level up from the GUI folder).

Yes, the F6 option is for installing a fresh OS completely anew during XP Setup. As I understand it, you are still booting into Windows (for the time being) from the IDE hdd. You just want to set up the SATA hdd itself as an additional hdd at the moment. The F6 option will not apply to your case.

Go back into Device Manager, either uninstall the current driver for the Silicon Image SATA controller, restart and reinstall the correct driver, or just select update driver, and point to the correct folder on the CD.

  jack 10:43 27 Jul 2004

Oh boy!
I too have been consdering adding a drive to my
ISA system only to find both ISA connectors
fully occupied and now I came across this string.
After reading in last week weeks MicroMart July 22 issue no 809 - on how easy it is.
I think I 'll wait abit

  Andknig 10:56 27 Jul 2004

Temp003, have done as you suggested. I uninstalled the drivers and SATALink, used browse to choose correct drivers. Now the drivers are installed, but still have the '!' attached to icon (in device manager), the following message is displayed 'this device cannot start, Error code 10'.


Satmansq - tried changing boot device to SCSI, but disk was not detected.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 6 review

Procreate's iPhone app offers new brushes, a larger canvas and better support for the iPhone 8/X

Best multi-room speakers for iPhone & Mac owners

Streaming : comment regarder le lancement de Xiaomi en France ?