Asus CDRW 4816A won't work

  [DELETED] 16:13 13 Nov 2003

I bought it in January as I built my own system, then yesterday it just stopped working. When I load a disc it clicks three times and then there's a sort of "powering down" sound. It tries again straight away but with the same result. Clicking on the icon results in a message saying the device isn't ready. Is my drive knackered after 10 months? Am I entitled to repair/replacement, and if so, to whom should I look for this, Asus or the vendor? I don't remember if there was a warranty card with it or not, and thus whether or not I filled it in...
Would much appreciate any help anyone could lend.

  [DELETED] 17:06 13 Nov 2003

does this happen with all cds?
If so, have you tried a lens cleaner cd? It maybe that the lens is dirty on the laser.

I stick a cleaner in mine every month and for over two years, my Ricoh has performed perfectly.

  [DELETED] 17:29 13 Nov 2003

Didn't think of that!

  [DELETED] 15:22 17 Nov 2003

Went and got a CD lens cleaner; it won't even spin that. The deal's the same, three clicks and we're out; from an amateur perspective it sounds like whatever motor spins the discs is knackered. Anyone got some advice on my recourse as the drive is only ten months old? I registered the drive on the Asus website (so, so late, I know) and filled in an online complaint form... so far nothing. Help!

  alan 2273 16:30 17 Nov 2003

Is it an option to take it back to where you purchased it and get them to test it, also are you using Nero if so look at this article click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

How to watch the World Cup for free on TV and online

PostPanic's latest short film is a thrilling love letter to film and TV history

Best external graphics cards (eGPUs) for Mac

Les meilleurs navigateurs internet (2018)