Shalimar 21:03 16 Mar 2014

I recently lost part of several files somehow but managed to recover what may be what I am looking for. Unfortunately everything seems to be in ASCII symbols. How do I covert this back to the original Excel files? I do not understand what is going on and would appreciate any help.

Thank you


  lotvic 23:59 16 Mar 2014

Can you tell us from the start what happened please.

What do you mean by "lost part of several files" how can you lose part of a file?

What are the file types you lost? (if excel then they would be .xls file type)

How did you lose them (What happened to make them lost)?

How did you manage to recover them? and what file type are they?

What program are you opening them in to discover they are ASCII symbols?

If you give us as many details as possible we may be able to help.

  Shalimar 11:07 17 Mar 2014

Sorry for any confusion but thank you for the quick reply LOTVIC. The file types I refer to are xls. They consisted of financial data in yearly format up to this year, but on opening one file recently the only data available was to 2011 and the rest had disappeared. I do not know how or when this happened. I used the file recovery program Quick Data Recovery which found a file with he right name but when I recovered it into Word and Notepad all I saw was what I described as ASCII symbols. I assumed that the file was xls. With another file I replaced one set of data with a new set only to find the old set opened up and the new set had disappeared. I can only think that I did not save the new set in this case. Kaspersky Internet 2014 did not show any problems and I have been confused ever since. I was expecting a file in plain English.

  lotvic 12:44 17 Mar 2014

"when I recovered it into Word and Notepad all I saw was what I described as ASCII symbols"

If you open an .xls file in Word or Notepad then yes it would look like that, so that is normal. Try opening it in Excel.

"financial data in yearly format up to this year, but on opening one file recently the only data available was to 2011 and the rest had disappeared"

Make a copies of your files and work with the copies (that keeps the originals safe so that you can safely try things out without fear of losing the original)

First make sure that you are viewing all of the open file - are the worksheets tabs showing at the bottom of screen?

Is the 'missing data' part of one worksheet or is each year on a separate worksheet and it is the worksheets that have seemingly disappeared?

  Shalimar 21:12 17 Mar 2014

I have tried opening the file in Excel but the results were the same although the name on the worksheet tab was the name of the file and not the set of data as in the original The original file had a data set on several worksheets with their own tab name. Each data set was for several years and it is the last three years of data that has gone missing on each worksheet within the file. The recovered data seems to be all in column A on one worksheet with the name of the main file on the tab. I have looked all over this worksheet but found nothing. I hope I have explained this clearly.

  lotvic 21:51 17 Mar 2014

It sounds as if the data has been deleted by someone else, or maybe the rows or columns have been Hidden? Look carefully at the Column letters and the row numbers to see if a block of them is missing - has been hidden.

Try the methods as per click here Methods for Recovering Data in Corrupted Excel Files

I'm not sure what to suggest to try with the file you have recovered using Quick Data Recovery.

  bumpkin 23:02 17 Mar 2014

Yet another case of no backup.

  Shalimar 10:15 19 Mar 2014

Thank you lotvic once again. I have tried what you suggested but to no avail. All is not lost as I will just type most of the information in again by hand. Incidently Bumpkin I had saved a backup before doing a clean install of Windows 7 and only discovered the problem upon reinstalling my files.

  lotvic 13:43 19 Mar 2014

Sometimes an explanation of why it happened is never found. Good that you are able to retype the info that was lost.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

How to use 3D Touch on iPhone

Comment importer des contacts d’un iPhone à un autre iPhone ?