Arrow keys on external keyboard copy screen image

  CliveyLondon 18:05 17 Feb 2005

If I press any of the movement keys, (e.g. Home, Page Down, up arrow) a full screen print (same effect as pressing Prt Scn) is copied to the clipboard when I use any external (wired or wireless) keyboard (PS2 keyboards with PS2/USB converter). I tried uninstalling HID Keyboard Device which as expected temporarily disabled the external keyboard, but the print screen problem continued after a restart. If I use the movement keys on the external keyboard’s numeric keypad (with Num Lock off), or use my laptop’s keyboard, I don’t get the problem.
I use Windows XP SP2 on a Toshiba Satellite laptop. I can't see any suspicious programs running in the background. The problem occurs when pressing the movement keys in all applications including DOS. It also happens in Safe Mode (the following were running: taskmgr.exe, ctfmon.exe, explorer.exe, svchost.exe, lsass.exe, services.exe, winlogon.exe, csrss.exe, smss.exe; these all seem valid programs). I know I can use the Office Clipboard to store multiple copies but don't want to rely on this.
I've searched online for this problem but haven't come up with anything and was wondering if anyone out there had some ideas. Many thanks for your responses. Clive

  groundhog 22:09 17 Feb 2005

It would appear that you have had your keys re-mapped. If that is what it is you will need to re-map them back.

The following link will help : click here

  CliveyLondon 00:17 18 Feb 2005

Many thanks for your advice Groundhog. I installed SharpKeys and tested it by changing the Home key (E0_47) to do just the Home Key action. After a reboot, unfortunately nothing had changed and Home still does a Home action as well as copying the screen to the clipboard.
I should have said earlier that my movement keys ALSO do what they should, e.g. Up arrow moves the cursor up and ALSO copies the screen to the clipboard. So they effectively have two actions.
N.B. According to SharpKeys, E0_37 is a PrtSc (Print Screen).

  groundhog 07:43 18 Feb 2005

Sorry my last info was not as helpfull as i'd hoped it would be, however When you have re-mapped your keys and before you re-boot do the keys respond in a single or dual function role.

I ask because if they remained in the dual function it would appear that there is a crossed circuit on the print scrn key.

If on the other hand they remain in the single function role until a reboot then it would indicate a software problem.

  CliveyLondon 08:34 18 Feb 2005

Thanks Groundhog. The movement keys continue with their dual action (PrtSc as well as the normal function of the key), whatever is set in SharpKeys. As a test, I remapped my Del key to the letter A. After reboot, pressing Del would give me an A but also copy the screen. Pressing the A key would give me an A but doesn't copy the screen to the clipboard. It's interesting that both external keyboards I've tried (one wired, one wireless) give the same dual function for the movement keys, suggesting a PC problem rather than say a keyboard specific one.

  groundhog 17:57 18 Feb 2005

It sounds like this is not a software program related problem and could be down to the Tosh not utilising a full 104 enhanced keyboard support.

There is one way to find out if this is normal with all Toshiba Satellite laptops, and that would be to go into a computer store and ask the staff if you could try a Tosh with an external keyboard.

I hope someone on the forum has had this problem and sorted it if at all possible.

Sorry I can't be any more specific

  CliveyLondon 18:07 20 Feb 2005

Many thanks for your suggestions Groundhog - I really appreciate your help.
I hadn't considered the keyboard support issue and will look into it. I have a feeling that this problem only arose after I had already been using the external keyboard for some time, but unfortunately didn't make a note and can't be sure. If I had, I could have seen what changes I'd made recently.
If anyone has found anything similar, I'd be very interested to know. Cheers, Clive.

  groundhog 13:56 27 Feb 2005

Looking around the web it would appear that the majority of USB connected keyboards require that an additional keyboard driver be installed.

I dont know if this will help but it's something else to consider

Best of luck

  CliveyLondon 11:02 18 Mar 2005

Thanks again for your update. I appear to have fixed my problem my using a different USB-PS2 converter; my original one that gave the clipboard problem was a doubler (one USB going to two PS2 ports). I now use a single USB-PS2 converter for my keyboard and can use movement keys without it copying a screen image.
I hope this helps anyone with the same problem (someone on Google Answers reported they had a similar problem).

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)