Are these driver download sites ok? (Looking for Synaptics Touchpad Driver)

  polymath 13:12 30 Oct 2013

When I Google a driver I want + my laptop model (details below if relevant), the first 3 pages of results all link to the following websites I'm not familiar with (so haven't gone to yet). Are they genuine? (+ .com, .fr etc)

Packard Bell Easynote BU45 laptop, Vista SP2. Looking for Synaptics Touchpad driver. The Synaptics website has its driver available for download, but warns against it for individuals, as manufacturers adapt it for each of their models. Packard Bell's no help. (Its support site was once an excellent resource, but whoever took over PB took it all down. To even access the site needs a recent model). Apparently, most Easynotes have a button for

I use a mouse, as I find it quicker & easier. To avoid moving the pointer with my sleeve while writing, I set my mouse to disable the touchpad when plugged in. The touchpad has mysteriously started being active again while the mouse is plugged in, and its settings page with the Disable button is all greyed out (with or without mouse plugged in). Maybe the driver got corrupted?. My model doesn't have a hardware button to turn the touchpad on & off (as most Easynotes apparently do), so my only option seems to be uninstalling/removing it. Before doing that, I'd like to have the driver handy in case the mouse gets lost/broken etc. For which a 3rd-party provider seems the only option.

Maybe I'll try the Wayback Machine (though I tried to find Packard Bell's forums there once with no luck). Or maybe I should just stick something over the touchpad? (Paper doesn't work, but beer-mat seems to...)

  onthelimit1 14:54 30 Oct 2013

I find most driver sites throw junk at you. Softpedia is better than most. Alternatively, you could try the free Touchfreeze which isolates the pad while you're typing.

  polymath 17:25 30 Oct 2013

Thanks for the tip about Touchfreeze, onthelimit1, but I wasn't being clear (sorry!). It's not just while typing that the touchpad's a nuisance to me.

I looked at Softpedia and found nothing applicable there (but looks useful & have bookmarked it for future reference - thanks. I also tried cnet (which I remembered using in the past), but nothing doing. Nothing doing at the Wayback Machine either (plenty of links there but pages not found; got redirected to the current Packard Bell website).

So it looks as if I've found yet another use for beer mats...

  alanrwood 17:34 30 Oct 2013
  jimforrest 13:19 31 Oct 2013

I have a Samsung laptop with a Synaptics Touchpad and have exactly the same problem with wretched thing moving the curser around. I deleted the driver - but it just reloaded at the next reboot! I'm not familiar with your machine, but I (originally) managed to turn the thing off by using Tools in Ccleaner and disabling it. That worked for a while - but it came back again (it's still disabled though). I also found I could disable it under Device Manager by selecting Mouse - then Other Pointing Devices. But it's back again!

Now I have to remember to press Fn+F5 every time I restart the machine as that turns it off.

If you find a permanent solution please tell us - it's driving me nuts! (On a previous Acer with the same problem I lifted the keyboard and pulled the touchpad strip cable out - but the keyboard isn't removable on the Samsung as it's within the laptop casing).

  polymath 22:13 01 Nov 2013

Thanks, retep888 - I hadn't spotted that little link!

Perhaps the filename you gave is the version that came with the laptop? The only Synaptics driver there for my model & OS is Synapticstp100120.exe (I presume 'tp' is for touchpad). It's dated 2010, about 3 years later than I bought the laptop, so maybe it's an improved version! I've downloaded it & will have a go with it tomorrow.

I've just noticed an unfinished sentence in my original post. 'Apparently, most Easynotes have a button for...' should continue 'turning the touchpad on & off, but mine hasn't'. I'm sure I typed the whole thing, but I've noticed some mysterious deletions since this problem started...

Yes jimforrest; if I ever find a real solution to this maddening bug, I'll certainly splash it all over the place!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro (2019) review

Designing a near-future Kowloon Walled City for Alita: Battle Angel

Microsoft brings Windows Defender ATP to the Mac

AirPower : date de sortie, prix et fiche technique