Archos MMJB20 not recognized

  Simon258 16:54 27 Dec 2004

Usually, when I plug my Archos MMJB20 into any USB port, it is automatically recognized as a USB Mass Storage Device.

In the last few days, the MMJB still recognizes that it is plugged into a USB port, by displaying "USB connected/in use - do not unplug", but the PC does not detect it. I have tried two cables with the same result and I have tried it on my sons laptop, again with the same result.

If I go into "run" and type in "diskmgmt.msc", it is there as "J:" as normal, but I cannot access it any other way.

Unfortunately, now every second or third time I plug it in, my PC locks up and I hev to reboot with the MMJB unplugged to carry on.

It's doing my head in now!!

Any clues anyone? Anyone sad enough to bve monitoring these postings when they should be eating turkey, xmas pud and shouting at their kids?

Happy New Year everyone


  Simon258 10:34 11 Jan 2005

No responses from anyone at all???! I think that the USB 1 input to my Archos is knackered, but the USB 2.0 cable from archos (that plugs into a different port on the MMJB)is a ridiculous £30! Anyone got a knackered MMJB and has a USB 2.0 cable they want to get rid of? I'll give you a tenner! Hello! Hello! Anyone out there?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

There's a new Gradient tool coming to Adobe Illustrator

Best Android emulators for Mac

Les drôles de questions à poser à votre assistant Google Home