Another Belkin Adapter problem

  pj123 12:05 04 May 2006

I have two desktop PCs both same specification.

Am on NTL BB and have a Belkin 54g router on the main PC and a Belkin USB adapter on the second.

When I try to log on to the internet on the second PC it takes a while before it comes up with:

Page cannot be displayed.

I have to go into the adapter and re-enter the "Key" everytime before I can access the internet with this PC.

After that everything is OK.

Should it not save all these details or is that normal?

  mgmcc 13:25 04 May 2006

Yes, the settings should be saved between sessions. If you are using XP SP2, I would suggest that you uninstall all of the belkin software for the USB adapter. Then boot the PC, plug in the adapter, let Windows find new hardware, insert the CD but *DON"T* run it (if it starts 'exit' from it), follow the hardware installation wizard and select the option to install from a specific location. "Browse" to the Drivers folder on the CD.

Once installed, use Windows' wireless networking software to manage it. In the Network Connections folder, right click the Wireless Network Connection and select "View Available Wireless Networks". highlight your router's SSID and click "Connect". You will be prompted to enter any WEP/WPA key.

Only if you click the "Disconnect" button, will you have to manually connect and enter the key again. Otherwise, connecting to your wireless network should be automatic.

  pj123 13:34 04 May 2006

Sorry, should have said both PCs running Win 98SE

  mgmcc 19:12 04 May 2006

OK, in that case you need to use the Belkin software. After you have connected, make sure that the network you are connected to is in the Profiles section because those are the details which are saved.

  pj123 10:21 05 May 2006

Thank you for that, mgmcc. Will check it out.

  pj123 16:06 06 May 2006

Have to put this one aside now, due to another problem with my Main PC and the Router.

click here

Which may or may not be why the problem on the 2nd pc exists.

Will tick this as resolved for now.

  Taff™ 08:35 07 May 2006

Is the USB adapter the F5D7050 model by any chance?

  pj123 13:15 07 May 2006

Hi Taff™, yes it is. Does that have a problem?

  mgmcc 13:53 07 May 2006

<<< Hi Taff™, yes it is. Does that have a problem? >>>

I don't have a problem with my F5D7050 - quite the reverse. It has worked faultlessly connecting to my router under Windows 98SE, Windows XP, Mac OS X and SuSE 10 Linux.

  Taff™ 13:55 07 May 2006

There have been three versions 1000, 2000 & the most recent 3000 series. I bought 6 of the latter last week and struggled with the drivers supplied on the Installation CD on the two Win98SE machines. Belkin Tech support linked me to click here Using the v3 driver resolved the issue on one of the machines but I finally tried a D-Link adapter which resolved the final machine.

I don`t have a F5D7050 adapter with me so I can`t tell you if the serial number on the back reveals which version it is. Belkin pointed me to the bar code on the packaging which clearly states 3000 on it. If yours is only a few months old I suggest you try the v3 software by following the link. Unplug the adapter. Remove the previous software from add/remove programmes and delete the adapter from device manager and reboot.

  pj123 15:28 07 May 2006

Another "thank you" is due Guys.

I have just downloaded v3 but can't try it yet until I solve my main router problem. The 7050 was given to me by my next door neighbour so all I got was the Install CD, Quick Installation Guide and the unit itself. No packaging so I don't have a barcode. The unit itself does have a MAC Address on it though.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Why this awful City of Los Angeles job ad for a graphic designer is actually brilliant

iMac Pro review

Les meilleures prises CPL (2018)