AMD and SP3

  Mike_R 15:25 03 Feb 2009

I've come late on this. In another thread I asked questions about SP3 and Norton which I had left "Switched on".
My son's PC is an Evesham AMD Athlon 64. After I loaded SP3
- the monitor remained blank after the PC was switched on, and the PC could only be switched off by unplugging it, or
- the monitor stuck on the BIOS opening screen and could not be switched off.
It would be helpful to know that these problems were caused by SP3.
Today, after I unplugged the PC, I plugged it in again and it immediately came to life and booted correctly (I hope). I took the opportunity to restore back before SP3 ( I think that the previous time I tried, it did not work).
I've found something about the HP AMD problem in the following:
"Because the image for both Intel and AMD is the same all have the intelppm.sys driver installed and running. That driver provides power management on Intel-based computers. On an AMD-based computer, amdk8.sys provides the same functionality,
Can anyone advise how I can find what drivers I've got installed (theIntel or AMD ones) to see whether my problem is similar?

  Pineman100 15:30 03 Feb 2009

I use Driver Max. click here

  woodchip 15:30 03 Feb 2009

All you need do is click search then type either of the files in to see what it finds

  jimv7 15:36 03 Feb 2009

Older thread click here

  Mike_R 15:56 03 Feb 2009

Thanks everyone. My son,s AMD PC has the intelppm.sys driver installed and not the AMD one. As it is to do with power management, I'm guessing that it would explain why the switching on and off was up the swannie.
But where do I go from here? Turn off the automatic update and leave SP3 well alone, or is there an easy (it has to be for me) workaround?

  woodchip 17:00 03 Feb 2009

Delete the Intel one and download and install the AMD And the right click on it and choose Install from the list then make sure its in the correct folder if not move the file to where the intel one was

  Mike_R 11:47 04 Feb 2009

Thanks. I see that I can easily delete the intel one but have searched the WEB about amdk8.sys with no luck, and am a bit uneasy about it as I don't really know what I am doing. Several sites warn about a virus with that name. The problem is that the PC is a three year old Evesham pre administration. I've emailed Microsoft but am wondering whether they will say that it is a manufacturer problem.
Any further advice welcome.

  Mike_R 15:11 06 Feb 2009

I'm b*ggered. Following a system restore removing SP3, the PC worked perfectly for three days and I thought that I had cracked it. Microsoft came back today with advice about removing the intel driver, so I switch on the PC only to get a screen saying no signal.
I've tried holding down F8, then Delete, but nothing happens. Unless it somehow clears itself, I can't get into the PC boot to do anything.
Any advice welcome, including "Chuck it out of the window, but shift the car first."

  woodchip 17:09 06 Feb 2009

will it go to safe mode? If not it looks like you will need to use the System CD to do a Repair. Not a Restore CD

  Mike_R 17:35 06 Feb 2009

No, it will not go into any mode, just sits there with a blank screen. I've changed the monitor to my own one, just to make sure that the latter is OK.
Can anyone recommend a suitable System CD, please?

  jimv7 17:37 06 Feb 2009

click here for a patch from hp to install sp3 with amd cpu.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?