AMD 64bit problems

  Timeout 23:27 08 Sep 2004
Locked

Ok so I've finally gone and done it! I've built my own!!

Used new Chaintech mobo, AMD 64bit processor, DDR ram and ATI Radeon graphics card. Will format and install Windows XP home when I've sorted everything out.

Every thing went together well enough, used my existing tower, CDRW, DVD, printer, scanner, modem (used as fax), broadband, hard drives - 2 of them in cradles so that I can let my grandchildren play without fear of them messing up my bookwork etc.

I used the kids hard drive (just in case things went wrong, don't want to use my drive until I know that it's all fine). As Me was installing the drivers up popped a blue screen with the following message

"Multi-function device (Standard Dual PCI IDE controller) has some child devices using 32-bit drivers & others using compatability-mode drivers. This configuration is not supported, so your computer has been halted to prevent corruption.
After you restart your computer Windows will use compatability-mode drivers for each child device attached to this multi-function device.
If you want to use 32-bit drivers obtain an updated driver, from your supplier, or disable the device.

Problem is I don't know what these 'child devices' are. Could it be the CDRW & DVD as they aren't working? They come up as there in the BIOS but Windows doesn't know they're there. As a result I can't use any of the CD's provided with the new bits, to install drivers, so I'm stuggling on with no sound & 16 colour 640 x480 graphics.

Anybody any idea why there's no CD or DVD drives please?

Thanks in advance for any help.

  Timeout 00:07 09 Sep 2004

The driver cd doesn't work.

Doesn't spin - nothing.

  Timeout 22:50 09 Sep 2004

I've had a 12 hour shift today and it shows at my age!

If jimv7 is right,
"Your motherboard drivers have not been loaded so you will not see cd's untill they are.",
would I be better off trying the drivers for the the mobo that I downloaded from the Chaintech site last night.
Then I could remove the optical drives and add them in one at a time?

  Timeout 00:28 10 Sep 2004

Well I tried that and I'd downloaded the wrong drivers :((

Will be back about 9pm tomorrow.

  bremner 10:56 10 Sep 2004

AMD 64 bit chips are completely 32 compatable - you do not need any 64 bit drivers. All the software is compatable.

Why build a system that will be obsoltite as soon as the 64 bit o/s comes along?

  Timeout 22:52 10 Sep 2004

Ok so I've unplugged the optical drives, got device manager up and there is a Primary IDE controller (single fifo) and a Secondary IDE controller (single fifo). If I try to remove either of these it brings up a message saying

This device is part of a multi-function device and cannot be removed independantly.
To remove this device, select and remove the parent. This will also remove any other devices that are part of this multi-function device.
Parent device: Standard Dual PCI IDE controller.

Will it be Ok to remove the parent device. Will it force the computer to use the CDRW & DVD? when I boot up again.

  Timeout 22:42 14 Sep 2004

Got it sorted!!!!

The culprits were the DVD & CD_RW drives.

As Medecine Hat suggested I took out the DVD and suddenly everything worked fine.

Put it back on and everything's still doing well.

Just got to try the other drive now, so maybe I'll be back yet!

Thanks to all for your help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy Book 2: Release date, price and specs

This First Man soundtrack vinyl cover art is exquisitely composed

How to watch Apple’s October 2018 iPad launch

Meilleurs VPN (2018)