Advisor Issue 177

  ElayEss 11:31 05 Feb 2010

I am having a problem installing Ashampoo's Magical Defrag 2.34 from the April issue DVD.
I get as far as selecting English, after which I get an Error notice displaying :-

Runtime error (at 82:1695)
Internal error: Unknown custom message name "uninstall_0044_msg" in "cm" constant.

Is it my problem only or the software?

Can anyone help please?

  badhair1963 11:37 05 Feb 2010

Try installing it in XP compatibility mode

  ElayEss 11:44 05 Feb 2010

Sorry badhair I should have said my OS is XP pro

  badhair1963 12:22 05 Feb 2010

I've just copied and pasted this text from a web page that I found. Basically, you'll have to run it in compatibility mode for an earlier system - Windows 95 or Windows 98.

Here’s how to access a program’s Compatibility Mode in XP:

Find the executable or program shortcut icon you’d like to run.
Right-click the icon and select Properties.
Click the Compatibility tab and place a checkmark next to the text labeled “Run this program in compatibility mode.”
Select the operating system that the program was originally intended to run on.
You may need to fine-tune the three fields under “Display Settings” if an older program requires 640×480 resolution or 256 colors.
Click Apply.

  badhair1963 12:24 05 Feb 2010

If all else fails, try this: click here

  Sea Urchin 12:40 05 Feb 2010

Why would you need to install it in compatibility mode? This version - Magical Defrag 2.34 is compatible with XP and Vista.

But to install from the PCA dvd you need to be using full administrative rights - shouldn't then be any problem. And with this version you'll get the full licence free.

  ElayEss 13:18 05 Feb 2010

Have tried to compatibility thing I'm told the program needs Windows NT v 5 or later, so I put in 2000 or nothing, altered the display but still came up with the same error.
I was trying to install the v 2 from the dvd as that was free for the licence.

Sea Urchin
As I am the only user I assume that I have full administrative rights - I have installed O&O SafeErase from the dvd with no problems!

  Sea Urchin 14:13 05 Feb 2010

"As I am the only user I assume that I have full administrative rights" - not necessarily. And it's not the whole DVD but this program in particular that needs admin rights.

When you get to the .exe file on the disk instead of just double-clicking hold your Shift key and right click on the file. Then select "Run as" and Administrator.

  ElayEss 14:26 05 Feb 2010

Yes already set to run as administrator and still comes up with the error screen

  Sea Urchin 14:50 05 Feb 2010

Just installed it on my XP Pro system without any trouble.

For the runtime error you could try checking in Internet explorer as follows:

Open Internet Explorer.
Click on Tools, then Internet Options.
Click on Advanced tab.
Scroll to Browsing.
Under Browsing,look for and check "Disable Script Debugging(Internet Explorer)"
Also check "Disable Script Debugging(other)".
Also make sure that "Display a notification about every script error" is unchecked.

Click Apply and OK and exit.

  ElayEss 11:55 06 Feb 2010

All those parameters already set to state you describe.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

ManvsMachine and other artists put Apple's iMac Pro to the test using powerful rendering tools

What to expect at Apple's 27 March education event

Comment filmer l’écran d’un iPhone ?