Add New Hardware wizard

  Magic VI 14:14 25 Jan 2004

I am doing up an old machine for a charity. Compaq Despro 633Intel Celeron system # 8107FR4Z0843. I have reformatted the drive and installed W98 SE. I found the 8107VGA Adaptor driver and installed that so the graphics is OK. I have fitted a modem which works (Intel 536EP V.92). I have also found and installed the Intel BP 810 Audio Zip driver.
When I check in System, Device Manager, there are no yellow question marks and all the drivers are present and working.
BUT when I fire up, the machine says New Hardware device found and looks for new drivers for 'an Unknown Device' with the 'Add New Hardware' wizard.
If I [cancel] everything fires up fine and works.
How can I get rid of this?

  VoG II 14:30 25 Jan 2004

What happens if you don't press Cancel - i.e. let it install the "new hardware"

  Magic VI 14:36 25 Jan 2004

If I [Search for the best driver] I cannot direct it where to look as I do not know what the 'unknown device' is suppose to do. I have tried everty driver on the W98 Se disc and they are all 'not written for this device'.
If I [Display a list..] I still do not know the sort of device so I am stumped.

  Big Elf 15:02 25 Jan 2004

The only thing I can think of is the Communication Ports. Are they listed in Device Manager?

There isn't any external devices other than Keyboard or Mouse connected is there?

  Magic VI 15:09 25 Jan 2004

Device manager , Ports show
COM Port 1 COM1
COM Port 2 COM2
ECP Printer port
with no problems indicated.

At the bottom of the list it shows my HP 920C printer as
usb HP colour printers v1.0
-> deskjet 920C #HU1BR6Q2ZVBl

The 920 is plugged into the usb hub on the machine.
There are no other devices hanging off the system.

  Big Elf 15:13 25 Jan 2004

Do you get the message if the printer is disconnected when you boot? I'm wildly guessing it might be the USB drivers.

  hugh-265156 15:17 25 Jan 2004

have the motherboard drivers been installed?

as VoG above what happens if you try and let windows install the driver?

try aida32 click here (any version)

click computer/summary here you will find all your hardware and links to driver updates listed.

  Magic VI 15:17 25 Jan 2004

I have just tried booting up with the printer unplugged and it gives the same messages.
Keep thinking!!

  you must be joking 15:22 25 Jan 2004

Haveing the same problem as Magic VI after a complete clean reinstall of Windows 98se still have an unknown device, but i now get a message about needing drivers for a with a CODE 28 ???

  Magic VI 17:05 25 Jan 2004

I have downloaded the aidee32 and run on the Compaq.
It looks very impressive but what do I do now?
I have been through every one of the 'screens' and cannot see anything untoward.
It says the motherboard is an Intel Solano i815; video adaptor is intel 82815 Graphics controller; 3D accelerator is Intel i572; Audio adaptor is Intel 82801 AA I/O Controller Hub AC'97 Audio Adaptor;
When I move the mouse over the right screen over the value column a box appears with manufacturers name and 'www links' for product info and driver downloads.

  ©®@$? 17:55 25 Jan 2004

aida and other software are good, but they only work well when the drivers are installed, as it cannot recognise the hardware without the drivers..

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HP Envy x2 review: Hands-on

How Sketch and InVision have revolutionised our design workflow

The best tech gifts for Christmas 2017

Les meilleurs jeux de société (2017)