Acer Notebook hard drive controller failure?

  silver78 17:01 01 Nov 2013

Picked up Acer 4000 ser: Notebook. At switch on HDD clicked for a while then defaulted to BIOS screen, reporting 'no harddisk'. I changed the drive for one I know works but although the clicking stopped BIOS does not see drive. I'm sure the drive is spinning up so appears to be getting power. Can I assume it's a HDD controller problem? I'm not well up on laptops so could someone advise me. Is the controller, software, hardware or both faulty? or could it be something else?. I've toyed with the idea of using a flashdrive as a boot disk but obviously it's not an ideal fix.

  Fruit Bat /\0/\ 20:30 01 Nov 2013

TRy fitting a new CMOS battery and resetting BIOS to defaults.

  silver78 22:08 01 Nov 2013

Thanks for reply fruit bat Hmm, I did note when I got it that the date/time was wrong which I reset.So could be a dead CMOS batt, even so why would BIOS report no HDD?

Just switched Notebook on after it's been put away for a week. BIOS date/time is OK so guess CMOS is OK. reset BIOS to defaults but still doesn't see HDD. On boot-up says 'no O/S' but if I try to install XP via CD Drive it will get as far as checking HDD etc. then reports 'no HDD'. Unfortunately this Notebook only has space for one HDD

  Fruit Bat /\0/\ 22:34 01 Nov 2013

Is that with the old drive or new drive?

Still worth changing the battery

  silver78 13:28 02 Nov 2013

That's with the 'new' drive. As for changing CMOS batt, that can be a pain as I think it's under the keyboard. Oh why can't they make them more accessible :(

  Fruit Bat /\0/\ 14:06 02 Nov 2013

On boot-up says 'no O/S'

which probably means its found the drive but no boot files on that drive

  silver78 14:22 02 Nov 2013

If BIOS can't 'see' the drive that would make sense. As I said, I've tried doing a re-install from CD drive. After loading install files it says 'no drive found'

  Fruit Bat /\0/\ 17:45 02 Nov 2013

I think you will need to try another drive if resetting BIOS does not allow it to detect the drive.

try removing and refitting the drive a few times might help to clean up the contacts.

  silver78 19:22 03 Nov 2013

Quick update. I fitted a drive that was password locked and although I can't read it it shows up in BIOS. I've ordered a new HDD which should arrive Tues or Weds. It appears my other spare drive is dead too. Will let you know result.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Razer Blade Pro 17 review

Enter graphic design heaven with these vintage Japanese posters

What is Apple Card and Daily Cash?

Les meilleures applications pour Android (2019)