acer Aspire wont get past acer screen

  MorningBard 15:45 30 Mar 2009

I'm trying to sort out a friends acer aspire (yes I can hear the groans from The problem seems to be the usual acer one where it won't boot beyond the acer press del and f12 screen. I've looked at past threads and tried everything using different psu, hard drives, resetting the bios, and processor, different keyboards and mice. The aspire in question is a T180-I97Z any help would be appreciate as its not even listed on acers website.

  woodchip 15:57 30 Mar 2009

If XP use a Full XP disc and do a Repair, any XP CD should work as long as its same version i.e Home or Prof etc

  MorningBard 16:03 30 Mar 2009

Hi Woodchip thanks for reply, I've tried that but it wont boot from cd i've tried even using the tab key to get into post but it just sits there does not respond to the keyboard so cant set to boot from cd its being a complete pig cant do anything with it, only boot up and get the acer logo screen saying to press del for bios or f12 for setup and keyboard does not respond.

  Fruit Bat /\0/\ 17:14 30 Mar 2009

REmove CMOS battery for 10 minutes to reset BIOS to defaults

if the motherboard has a clear BIOS jumper use that to reset BIOS.

  woodchip 18:49 30 Mar 2009

Try using a PS/2 Keyboard to get into BIOS, you must be using a USB and its most likely not switched on in BIOS

  MorningBard 19:18 30 Mar 2009

I have tried resetting bios by removing battery and re setting the jumpers and ps2 keyboard is the one i am using i did try a usb just in case and to remove that alternative. I've even tried an old mouse as that was a suggestion in one of the old threads on here. You keep suggesting and i'll keep trying

  skidzy 20:08 30 Mar 2009

Have you seen my postings on this topic, i do not have them to hand at the moment but i remember checking the mobo for a dual bios and reset both using the jumpers (not all Acers have the dual bios).

  MorningBard 20:27 30 Mar 2009

yes i've seen you postings on this and have looked for another set of jumpers but I cant see any only one set of red ones I'm quite techy and its beating me dont think i'd have one myself after this not a good ad for them at all

  skidzy 21:04 30 Mar 2009

For what its worth,this problem comes up quite regularly and no one has the exact cure (i got lucky).

I have stripped these Acers down and replaced almost every component one by one and still the problem persists.

Personally, i think its a bios issue with those Mobos and not something that is not easily fixed without a new bios chip.

A little tip to try (no promises);

Discharge the capacitors by turning the computer off and remove the wall plug and hold in the start button for 10 seconds,then reboot the computer after 10 minutes.
Sounds like an old wives tale,but can work for some.

  MorningBard 21:31 30 Mar 2009

tried that and its not worked this is becoming a pain been working on it for two days now cant get into pc to make any changes very frustrating

  woodchip 22:02 30 Mar 2009

will it boot to bios without hard drive connected

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

Creative studio Omnibus' brand identity for We Said Enough, a non-profit against sexual misconduct

What to ask Siri on the HomePod

Meilleurs VPN (2018)