Acer Aspire - Laptop not turning on or responding.

  BeczN 04:21 12 May 2016

Hi all,

I went to turn on my laptop this morning (Acer Aspire E1-572) and found I got jigger all from all attempts to do so. I'm not quite sure what has caused it to change overnight (it was working fine yesterday) but I'm really starting to worry about it. I'm not that good with technical computer things anyway, and would really rather not have to take it anywhere to be looked at as I've got a thing about handing over a computer that has access to my confidential things like emails, social media account, banking details, but equally I cannot just let the computer sit unfixed when I need access to it for college work (extremely baaaad timing for a final year degree student) and due to being busy it's been a while since I've backed up some fairly valued files like my photos and work documents, which I'm now lamenting a potential loss of.

To describe the issue, I've summarised a few of the key problems and would appreciate any help or advice as this is really concerning me now: - The laptop is plugged in and showing a single blue light when connected to the mains as per usual. (I have tried using multiple plug sockets to be certain it wasn't that, all with no success). - When pressing the on button, I get absolutely no on-screen response and get about 10 seconds of a second little blue light, before that too blinks out. The fan is not activated and there is no audible reaction to the power button being pressed (no beep/whirring) or the light changing colour as it normally does. - I have removed the battery, left it out for a little while, and replaced it. I'm not tech savvy so unsure what, if anything, this would do to benefit my computer but it has been suggested for others reporting similar problems to no avail on my part. Others have also suggested holding the power button for anywhere from 20-45 seconds - this gets me nowhere, with or without the battery.

Other information: - As of lately it has been considerably slow when doing updates, sometimes seeming to get absolutely nowhere at all. On occasion I've had to turn it off mid-update in order to restart and do some quite important work that I couldn't put off for hours on end. Other than that there has been no noticeable effect on laptop performance such as lagging response/excessive noise or overheating. - Overnight I had left in a multi-charger USB which I don't usually do, although it wasn't connected to anything. I usually use one single adapted to charge my graphics tablet pen. - There was a disk in the disk drive (also normal for me) but I have since manually removed it. - My computer usage is very simple; limited to photoshop and college work or the odd game, no exciting fancy stuff that might cause it to suddenly have a computer stroke and kick the bucket. - It's only 2 years old, runs really nicely 99% of the time since a few drivers were updated (internet related) last year.

Is there anything I could be looking at specifically such as a kaput internal problem (motherboard?) or virus (all recent scans have been fine and I've a very dull and predictable internet browsing repertoir so introducing any new sites isn't really something I would consider to be pertinent at the present moment).

Any advice, tips, likely course of action I could take to get it fixed, would all be greatly appreciated. If it's a technical issue requiring parts or (god forbid) replacement, I'll be understandably devestated, not least of all working on a student's budget, but for the sake of my computer and files I'll be willing to do what needs to be done if push comes to shove. (Ps. if at all possible when using particularly tech lingo, if there's a stupid person translation, I would be most grateful. I've got the basics down but by no means do I understand the internal workings of a computer).

Thanks in advance!

(This question has also been submitted in the Acer advice forum for anyone who would suggest it ought to be redirected to that particular site).

  Fruit Bat /\0/\ 12:45 12 May 2016

Remove power cable - remove battery - press and hold power button for 20 seconds

reconnect power lead and re try to boot.

**1. As a student back up daily 2. Never kill the power while in mid update**

  BeczN 20:27 12 May 2016

Fruit Bat /\0/\ 12:45 12 May 16 Remove power cable - remove battery - press and hold power button for 20 seconds reconnect power lead and re try to boot. 1. As a student back up daily 2. Never kill the power while in mid update

Thanks for getting back to me. Yes, I am a fool for noobishly defying all the fundamentals of technology (thou shalt not quit the update and will perform frequent back-ups). To update in this, no luck with the method described and - if it's at all possible for the situation to be worse - my computer no longer seems to be recognising the charge cable at all. My last blue light has blinked its last... I have tried replacing with the cable with another identical one from a friend but to no success in trying to get it to show any signs of life. Looking more and more likely that I'm going to have to take it somewhere to be looked at :(

  Fruit Bat /\0/\ 13:46 13 May 2016

Is the DC power socket loose?

you could remove HDD and place in caddy to connect to another PC to get at your data. click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Visual Trends 2018: This year’s must-know colour, design, branding & photography trends

iMac Pro review

Apple Music : comment obtenir 3 mois gratuits ?