Access permission on mixed network

  Gaven 19:23 14 Dec 2005

I have recently set up a mixed network using a Belkin G125 Router connected to the main computer by Ethernet and by USB wireless adapter to the second computer. The main computer can access shared files and a Printer on the second computer. The second acomputer can access the printer functions of an all in one Photo printer but not the scanner. It cannot access shared files on the main computer. The second computer uses Windows Firewall. The main computer has this disabled but uses Zone Alarm firewall with the second computer in the trusted zone. Turning Zone Alarm off makes no difference. Any suggestions?

  mgmcc 21:07 14 Dec 2005

<<< The second acomputer can access the printer functions of an all in one Photo printer but not the scanner >>>

Windows "File & Printer Sharing" only supports printing over the network, it doesn't support the remote use of scanners.

<<< It cannot access shared files on the main computer. >>>

Which version of Windows is the "main" PC running. XP Professional is more problematical than Home Edition. You may have to be logged into both PCs with an identical Username/Password. Have a look at this page - click here

  Gaven 11:18 15 Dec 2005

Thanks mgmcc. I should have mentioned that I am running XP Home SP2 on both machines without password access as I trust my wife. She will have to live with the scanner issue, but giving access to shared files would be useful.

  mgmcc 12:24 15 Dec 2005

Normally I would have suspected a firewall problem, but if printer sharing is working, that cannot be the issue. Have you actually set at least one folder as "shared" in its Properties? The "Shared Documents" folder is intended for files that are to be shared between User Accounts set up in the PC, but if you want the folder to be available as a "Network Share", it still needs to be set as "shared" in its Properties.

  Gaven 13:42 16 Dec 2005

Dear mgmcc

The "Shared Documents" folder on the main computer is configured as shared, as is a sub folder. I still get the message when trying to access from the second computer: -
"\\(computer name) is not accessible. You might not have permission to use this network resource. Contact the administrartor of this server to find out if you have access permissions. Access is denied."

The all in one printer is connected to the USB2 card on the main computer. It does not appear in the Printers and Faxes list on the second computer but shows up in printer choices in Word and other programs, and can be configured remotely.

  mgmcc 14:15 16 Dec 2005

As you have Zone Alarm in the main computer, try this:

Open Zone Alarm, select the Firewall tab on the left and then the Zones tab at the top. Click the "Add" button and select "Subnet". Type in...

IP Address -

Subnet Mask -

Description - {anything} but it needs an entry.

Click OK to close the box, then click Apply. If you have Zone Alarm in the other computer, do exactly the same.

See if that gets you any further forward.

  Gaven 01:26 17 Dec 2005

Dear mgmcc

I have tried your suggestion and even specified the second computer's IP address. Still the same error message.
The router IP is and the Ethernet adapter is listed in Zone alarm as as a subnet, with mask

  mgmcc 08:31 17 Dec 2005

Try creating a new folder in the root of "C"drive, set it as "shared" and see if you can access it using the full path. For example, if the new folder is called "Miscellaneous", try accessing it from the 'client' PC by opening My Network Places and entering in the address bar:

\\{computer name}\Miscellaneous

If that doesn't work, something else to check (but ONLY if you are comfortable accessing and editing the registry) -

Open Regedit and navigate to:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\ Lsa

look for a DWORD "restrictanonymous" and see what the value is. If it is anything other than 0 (zero), right click the DWORD, select MODIFY and change the decimal value to 0 (zero).

A word of warning, there is a DWORD "restictanonymoussam" just below the one you want - DO NOT change this.

Close regedit and reboot the computer.

I assume that each PC has its own name but that they are both in the SAME Workgroup?

  Gaven 18:35 17 Dec 2005

Dear mgmcc

Editing the Registry as you suggested seemed to be the obvious first thing to try, and it worked. Thanks.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Majority of illustrators don’t earn enough to live from, new survey shows

iPhone X problems

Word gratuit : comment télécharger le logiciel de Microsoft ?